aboutsummaryrefslogtreecommitdiff
path: root/games/glasteroids
diff options
context:
space:
mode:
Diffstat (limited to 'games/glasteroids')
-rw-r--r--games/glasteroids/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index c0dae1f4edb9..87efb65cd33b 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -25,6 +25,12 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
@${MKDIR} ${DATADIR}
@@ -39,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>