aboutsummaryrefslogtreecommitdiff
path: root/games/gma
diff options
context:
space:
mode:
Diffstat (limited to 'games/gma')
-rw-r--r--games/gma/Makefile27
-rw-r--r--games/gma/distinfo2
-rw-r--r--games/gma/files/patch-apprentice.cc11
-rw-r--r--games/gma/files/patch-moves.h13
-rw-r--r--games/gma/files/patch-scores.cc11
-rw-r--r--games/gma/files/patch-scores.h16
-rw-r--r--games/gma/pkg-descr9
7 files changed, 0 insertions, 89 deletions
diff --git a/games/gma/Makefile b/games/gma/Makefile
deleted file mode 100644
index bfa8b58ed73e..000000000000
--- a/games/gma/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# Created by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
-# $FreeBSD$
-
-PORTNAME= gma
-PORTVERSION= 0.6
-CATEGORIES= games
-MASTER_SITES= http://www.student.nada.kth.se/~d92-jwa/code/gma/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Go-moku game which learns playing the game from studying its opponent
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
-
-LICENSE= GPLv2+
-
-GNU_CONFIGURE= yes
-
-PLIST_FILES= bin/apprentice.gmaplayer bin/gma-console
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|stl\.h|map| ; \
- s|^CXXFLAGS|#CXXFLAGS|' ${WRKSRC}/configure
-
-.include <bsd.port.mk>
diff --git a/games/gma/distinfo b/games/gma/distinfo
deleted file mode 100644
index 5dcc121da64a..000000000000
--- a/games/gma/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gma-0.6.tar.gz) = 8ad3524a906128c196f8a5052caf2e3fd65f9ffa18fd71589624855f1b48f3e6
-SIZE (gma-0.6.tar.gz) = 43441
diff --git a/games/gma/files/patch-apprentice.cc b/games/gma/files/patch-apprentice.cc
deleted file mode 100644
index bce644b27607..000000000000
--- a/games/gma/files/patch-apprentice.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/apprentice.cc.orig
-+++ src/apprentice.cc
-@@ -32,6 +32,8 @@
- #include "moves.h"
- #include "gma.h"
-
-+using std::string;
-+
- #define BOARD_SIZE 50
- #define MAX_DEPTH 2
-
diff --git a/games/gma/files/patch-moves.h b/games/gma/files/patch-moves.h
deleted file mode 100644
index cecae223de52..000000000000
--- a/games/gma/files/patch-moves.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/moves.h.orig
-+++ src/moves.h
-@@ -24,7 +24,9 @@
-
- #include "pattern.h"
-
--#include <stl.h>
-+#include <map>
-+
-+using std::map;
-
- class Moves:map<Pattern,int>
- {
diff --git a/games/gma/files/patch-scores.cc b/games/gma/files/patch-scores.cc
deleted file mode 100644
index 52b1542eadd2..000000000000
--- a/games/gma/files/patch-scores.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/scores.cc.orig Sun May 18 19:20:37 2003
-+++ src/scores.cc Sun May 18 19:20:51 2003
-@@ -50,7 +50,7 @@
- return result;
- }
-
--void Scores::mark_good(const Pattern pattern, int goodness = 1)
-+void Scores::mark_good(const Pattern pattern, int goodness)
- {
- // Mark this position as beneficial
- int i;
diff --git a/games/gma/files/patch-scores.h b/games/gma/files/patch-scores.h
deleted file mode 100644
index 1195cfaf6461..000000000000
--- a/games/gma/files/patch-scores.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/scores.h.orig Mon Apr 17 02:52:22 2000
-+++ src/scores.h Sun May 18 19:19:41 2003
-@@ -22,10 +22,12 @@
- #ifndef SCORES_H
- #define SCORES_H
-
--#include <stl.h>
-+#include <map>
- #include <string>
- #include "pattern.h"
-
-+using std::map;
-+
- class Scores
- {
- public:
diff --git a/games/gma/pkg-descr b/games/gma/pkg-descr
deleted file mode 100644
index 257e0e807900..000000000000
--- a/games/gma/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-GMA or "The Go-Moku Apprentice" is a computerized go-moku player that
-learns playing the game entirely from its opponent. It was written for
-fun by Johan Walles (d92-jwa@nada.kth.se) in October 1998.
-
-The goal of Go-Moku is to get five (or more) marks in a row
-(horizontally, vertically or diagonally). You get to put one mark each
-time it is your turn.
-
-WWW: http://www.student.nada.kth.se/~d92-jwa/code/