aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-games/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnome-games/Makefile')
-rw-r--r--games/gnome-games/Makefile39
1 files changed, 20 insertions, 19 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 93e720df1317..cc387dde7df6 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/games/gnome-games/Makefile,v 1.206 2009/10/20 10:40:07 avl Exp $
+# $MCom: ports/games/gnome-games/Makefile,v 1.218 2010/04/27 19:42:25 kwm Exp $
#
PORTNAME= gnome-games
-PORTVERSION= 2.28.2
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,10 +15,13 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= The game applications package for the GNOME 2 Desktop Environment
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
LIB_DEPENDS= guile.20:${PORTSDIR}/lang/guile \
clutter-gtk-0.10.0:${PORTSDIR}/graphics/clutter-gtk \
clutter-glx-1.0.0:${PORTSDIR}/graphics/clutter \
ggzmod.5:${PORTSDIR}/games/ggz-client-libs
+RUN_DEPENDS= seed:${PORTSDIR}/devel/seed \
+ ${LOCALBASE}/share/gir-1.0/GConf-2.0.gir:${PORTSDIR}/devel/gir-repository-gconf2
USE_BZIP2= yes
USE_PYTHON= yes
@@ -27,30 +29,29 @@ USE_GETTEXT= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui \
+USE_GNOME= gnomeprefix gnomehack intlhack \
librsvg2 desktopfileutils pygnomedesktop gnomedocutils
USE_GSTREAMER= vorbis ogg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sound=gstreamer \
- --disable-tests \
- --enable-introspection=no
+ --disable-tests
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GCONF_SCHEMAS= aisleriot.schemas blackjack.schemas glchess.schemas \
- glines.schemas gnect.schemas gnibbles.schemas \
- gnobots2.schemas gnome-sudoku.schemas gnometris.schemas \
- gnomine.schemas gnotravex.schemas gnotski.schemas \
- gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas
+GCONF_SCHEMAS= aisleriot.schemas glchess.schemas glines.schemas \
+ gnect.schemas gnibbles.schemas gnobots2.schemas \
+ gnome-sudoku.schemas gnomine.schemas gnotravex.schemas \
+ gnotski.schemas gtali.schemas iagno.schemas lightsoff.schemas \
+ mahjongg.schemas quadrapassel.schemas swell-foop.schemas
CONFLICTS= sol-1.0.* glchess-[0-9]* gnomesudoku-[0-9]*
-DSC_FILES= iagno/iagno-client.dsc gnect/data/gnect-client.dsc \
- gnibbles/gnibbles-client.dsc
+#DSC_FILES= iagno/iagno-client.dsc gnect/data/gnect-client.dsc \
+# gnibbles/gnibbles-client.dsc
-MAN6= blackjack.6 glchess.6 glines.6 gnect.6 gnibbles.6 gnobots2.6 \
- gnome-sudoku.6 gnometris.6 gnomine.6 gnotravex.6 gnotski.6 \
- gtali.6 iagno.6 mahjongg.6 same-gnome.6 sol.6
+MAN6= glchess.6 glines.6 gnect.6 gnibbles.6 gnobots2.6 \
+ gnome-sudoku.6 gnomine.6 gnotravex.6 gnotski.6 \
+ gtali.6 iagno.6 mahjongg.6 quadrapassel.6 sol.6
.include <bsd.port.pre.mk>
@@ -65,9 +66,9 @@ post-patch:
post-install:
${MKDIR} ${PREFIX}/share/ggz/gnome-games
-.for dsc in ${DSC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${dsc} ${PREFIX}/share/ggz/gnome-games/${dsc:T}
-.endfor
+#.for dsc in ${DSC_FILES}
+# ${INSTALL_DATA} ${WRKSRC}/${dsc} ${PREFIX}/share/ggz/gnome-games/${dsc:T}
+#.endfor
@-update-desktop-database
.include <bsd.port.post.mk>