aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-games/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnome-games/Makefile')
-rw-r--r--games/gnome-games/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 7bf15f1f2677..e9bf68302810 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/games/gnome-games/Makefile,v 1.139 2007/03/13 17:05:22 mezz Exp $
+# $MCom: ports/games/gnome-games/Makefile,v 1.159 2007/10/16 03:43:45 mezz Exp $
#
PORTNAME= gnome-games
-PORTVERSION= 2.18.2.1
+PORTVERSION= 2.20.1
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -27,6 +27,7 @@ USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui \
librsvg2 desktopfileutils pygnomedesktop gnomedocutils
+USE_GSTREAMER= vorbis ogg
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,8 +36,7 @@ GCONF_SCHEMAS= aisleriot.schemas blackjack.schemas glchess.schemas \
glines.schemas gnect.schemas gnibbles.schemas \
gnobots2.schemas gnometris.schemas gnomine.schemas \
gnotravex.schemas gnotski.schemas gtali.schemas \
- iagno.schemas libgnomegames.schemas mahjongg.schemas \
- same-gnome.schemas
+ iagno.schemas mahjongg.schemas same-gnome.schemas
CONFLICTS= sol-1.0.* glchess-[0-9]* gnomesudoku-[0-9]*
@@ -47,15 +47,9 @@ LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|share|share/gnome|g ; \
- s|/usr/local|${PREFIX}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
${WRKSRC}/gnome-sudoku/src/lib/defaults.py.in \
${WRKSRC}/glchess/src/lib/defaults.py.in
- @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share/gnome|' \
- ${WRKSRC}/gnome-sudoku/src/gnome-sudoku \
- ${WRKSRC}/glchess/src/glchess \
- ${WRKSRC}/gnome-sudoku/src/lib/dialog_swallower.py \
- ${WRKSRC}/gnome-sudoku/src/lib/game_selector.py
post-install:
@-update-desktop-database