aboutsummaryrefslogtreecommitdiff
path: root/games/gnomegames/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnomegames/Makefile')
-rw-r--r--games/gnomegames/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/games/gnomegames/Makefile b/games/gnomegames/Makefile
index 560e68782204..82fe646ec4b1 100644
--- a/games/gnomegames/Makefile
+++ b/games/gnomegames/Makefile
@@ -15,7 +15,7 @@ DISTNAME= gnome-games-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore \
- guile.6:${PORTSDIR}/lang/guile
+ guile.9:${PORTSDIR}/lang/guile
RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -30,4 +30,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>