aboutsummaryrefslogtreecommitdiff
path: root/games/gnubg
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnubg')
-rw-r--r--games/gnubg/Makefile33
-rw-r--r--games/gnubg/distinfo10
-rw-r--r--games/gnubg/pkg-descr2
-rw-r--r--games/gnubg/pkg-plist21
4 files changed, 44 insertions, 22 deletions
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index c2cc52b4eb71..3a297df73800 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -6,31 +6,30 @@
#
PORTNAME= gnubg
-PORTVERSION= 0.13.0
-PORTREVISION= 1
+PORTVERSION= 0.14.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA} \
http://triaez.kaisei.org/~kaoru/misc/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${DISTNAME}.tar.gz \
- gnubg.weights-${GNUBG_WEIGHTS_VERSION}.gz
+ gnubg.weights-${GNUBG_WEIGHTS_VERSION}.gz \
+ gnubg_os0.bd.gz gnubg_ts0.bd.gz
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= kaoru@kaisei.org
COMMENT= GNU Backgammon
-BROKEN= "Broken pkg-plist"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-17
-
MAN6= gnubg.6
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gtk20
+USE_GETTEXT= yes
+USE_GNOME= libxml2 gtk20
WANT_ESOUND= yes
+CONFIGURE_ARGS+= --with-x --with-gtk2 --enable-nls --with-timecontrol --without-board3d
+
.if defined(HAVE_ESOUND)
CONFIGURE_ARGS += --with-esound
.else
@@ -39,20 +38,30 @@ CONFIGURE_ARGS += --without-esound
.if defined(WITH_NAS)
CONFIGURE_ARGS += --enable-nas
+.else
+CONFIGURE_ARGS += --disable-nas
.endif
.if defined(WITH_GUILE)
CONFIGURE_ARGS += --with-guile
+.else
+CONFIGURE_ARGS += --without-guile
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= 2.0+
+CONFIGURE_ARGS += --with-python
+.else
+CONFIGURE_ARGS += --without-python
.endif
INFO= gnubg
-GNUBG_WEIGHTS_VERSION=0.13b
+GNUBG_WEIGHTS_VERSION=0.14
post-extract:
${GUNZIP_CMD} --stdout ${DISTDIR}/${DIST_SUBDIR}/gnubg.weights-${GNUBG_WEIGHTS_VERSION}.gz > ${WRKSRC}/gnubg.weights
-
-post-build:
- @(cd ${WRKSRC} && ./makebearoff -t 6x6 -f gnubg_ts0.bd)
+ ${GUNZIP_CMD} --stdout ${DISTDIR}/${DIST_SUBDIR}/gnubg_os0.bd.gz > ${WRKSRC}/gnubg_os0.bd
+ ${GUNZIP_CMD} --stdout ${DISTDIR}/${DIST_SUBDIR}/gnubg_ts0.bd.gz > ${WRKSRC}/gnubg_ts0.bd
.include <bsd.port.mk>
diff --git a/games/gnubg/distinfo b/games/gnubg/distinfo
index 133920b5f6a7..76900a55c60b 100644
--- a/games/gnubg/distinfo
+++ b/games/gnubg/distinfo
@@ -1,2 +1,8 @@
-MD5 (gnubg/gnubg-0.13.0.tar.gz) = 91db5727b6589dbfd410e6ce1683fa95
-MD5 (gnubg/gnubg.weights-0.13b.gz) = b8ab016c1d948a32830952ba6e368947
+MD5 (gnubg/gnubg-0.14.1.tar.gz) = fb5b6283daf6da99146a3df785c4f446
+SIZE (gnubg/gnubg-0.14.1.tar.gz) = 3773258
+MD5 (gnubg/gnubg.weights-0.14.gz) = 9f1154a9b327954a260726aa6aa6eea5
+SIZE (gnubg/gnubg.weights-0.14.gz) = 460747
+MD5 (gnubg/gnubg_os0.bd.gz) = 4015327219322eacab5ddd58f6fa268d
+SIZE (gnubg/gnubg_os0.bd.gz) = 906720
+MD5 (gnubg/gnubg_ts0.bd.gz) = 01bd14c184bd701ae484618eb8acec6e
+SIZE (gnubg/gnubg_ts0.bd.gz) = 5899380
diff --git a/games/gnubg/pkg-descr b/games/gnubg/pkg-descr
index d589891e3c02..969f09184f21 100644
--- a/games/gnubg/pkg-descr
+++ b/games/gnubg/pkg-descr
@@ -4,4 +4,4 @@ network. Though it already plays on a very high level, it's still
work in progress. You may play GNU Backgammon using the command
line or a graphical interface (based on GTK+).
-WWW: http://www.gnu.org/software/gnubg/gnubg.html
+WWW: http://www.gnubg.org/
diff --git a/games/gnubg/pkg-plist b/games/gnubg/pkg-plist
index b93b4d276980..ab142c1211a3 100644
--- a/games/gnubg/pkg-plist
+++ b/games/gnubg/pkg-plist
@@ -1,12 +1,19 @@
bin/gnubg
bin/makebearoff
+bin/makehyper
share/gnubg/annealing.png
+share/gnubg/boards.xml
share/gnubg/gnubg.gtkrc
share/gnubg/gnubg.wd
share/gnubg/gnubg.xml
share/gnubg/gnubg_os0.bd
share/gnubg/gnubg_ts0.bd
-share/gnubg/boards.xml
+share/gnubg/rulfig1.png
+share/gnubg/rulfig2.png
+share/gnubg/rulfig3.png
+share/gnubg/rulfig4.png
+share/gnubg/rulfig5.png
+share/gnubg/texinfo.dtd
share/gnubg/met/catalog
share/gnubg/met/jacobs.xml
share/gnubg/met/met.dtd
@@ -14,11 +21,6 @@ share/gnubg/met/met.xsl
share/gnubg/met/snowie.xml
share/gnubg/met/woolsey.xml
share/gnubg/met/zadeh.xml
-share/gnubg/rulfig1.png
-share/gnubg/rulfig2.png
-share/gnubg/rulfig3.png
-share/gnubg/rulfig4.png
-share/gnubg/rulfig5.png
share/gnubg/sounds/chequer.wav
share/gnubg/sounds/dance.wav
share/gnubg/sounds/double.wav
@@ -31,10 +33,15 @@ share/gnubg/sounds/move.wav
share/gnubg/sounds/resign.wav
share/gnubg/sounds/roll.wav
share/gnubg/sounds/take.wav
-share/gnubg/texinfo.dtd
@dirrm share/gnubg/met
@dirrm share/gnubg/sounds
@dirrm share/gnubg
share/locale/da/LC_MESSAGES/gnubg.mo
share/locale/de/LC_MESSAGES/gnubg.mo
+share/locale/en_US/LC_MESSAGES/gnubg.mo
+share/locale/en@quot/LC_MESSAGES/gnubg.mo
+share/locale/fr/LC_MESSAGES/gnubg.mo
+share/locale/is/LC_MESSAGES/gnubg.mo
+share/locale/it/LC_MESSAGES/gnubg.mo
share/locale/ja/LC_MESSAGES/gnubg.mo
+share/locale/tr/LC_MESSAGES/gnubg.mo