aboutsummaryrefslogtreecommitdiff
path: root/games/gnuchess/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnuchess/Makefile')
-rw-r--r--games/gnuchess/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/games/gnuchess/Makefile b/games/gnuchess/Makefile
index 4a9c84f5c46f..6d216a177449 100644
--- a/games/gnuchess/Makefile
+++ b/games/gnuchess/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gnuchess
-PORTVERSION= 6.0.3
+PORTVERSION= 6.1.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= chess
@@ -13,15 +13,13 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= "Classic" Gnu Chess
INFO= gnuchess
-PLIST_FILES= bin/gnuchess bin/gnuchessu bin/gnuchessx
-PORTDOCS= *
-PORTDATA= *
+USES= shebangfix
+SHEBANG_FILES= doc/quotes.rb
OPTIONS_DEFINE= OPENING_BOOK
OPTIONS_DEFAULT= OPENING_BOOK
OPENING_BOOK_DESC= Install opening book (25 MB download)
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENING_BOOK}
@@ -29,6 +27,14 @@ DISTFILES+= book_1.02.pgn.gz
EXTRACT_ONLY+= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
.endif
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" MKDIR_P="${MKDIR}"
@@ -44,10 +50,10 @@ post-build:
.endif
post-install:
- ${LN} -f ${PREFIX}/bin/gnuchess ${PREFIX}/bin/gnuchessx
+ cd ${STAGEDIR}${PREFIX}/bin && ${LN} -f gnuchess gnuchessx
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/doc/* ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>