aboutsummaryrefslogtreecommitdiff
path: root/games/grhino/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/grhino/Makefile')
-rw-r--r--games/grhino/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/grhino/Makefile b/games/grhino/Makefile
new file mode 100644
index 000000000000..ed4016dd3306
--- /dev/null
+++ b/games/grhino/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: grhino
+# Date created: 21 Sep 2002
+# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grhino
+PORTVERSION= 0.7.0
+CATEGORIES= games gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rhino
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs gnomeprefix
+USE_PERL5_BUILD=yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>