aboutsummaryrefslogtreecommitdiff
path: root/games/gtypist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gtypist/Makefile')
-rw-r--r--games/gtypist/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/games/gtypist/Makefile b/games/gtypist/Makefile
index e141492c8f6a..23dd00830778 100644
--- a/games/gtypist/Makefile
+++ b/games/gtypist/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= gtypist
-PORTVERSION= 2.8.5
+PORTVERSION= 2.9
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -13,12 +13,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= naddy@FreeBSD.org
COMMENT= Interactive typing tutor
-USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= EMACS=no
+CPPFLAGS= -I${WRKDIR}/include
MAKE_JOBS_SAFE= yes
-INFO= gtypist gtypist.cs
+INFO= gtypist gtypist.cs gtypist.es
MAN1= gtypist.1 typefortune.1
.if !defined(WITHOUT_NLS)
@@ -29,4 +29,9 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+# wide curses header expected at <ncursesw/ncurses.h>
+pre-configure:
+ @${MKDIR} ${WRKDIR}/include
+ @${LN} -sf /usr/include ${WRKDIR}/include/ncursesw
+
.include <bsd.port.mk>