aboutsummaryrefslogtreecommitdiff
path: root/games/hlserver-psychostats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/hlserver-psychostats/Makefile')
-rw-r--r--games/hlserver-psychostats/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/games/hlserver-psychostats/Makefile b/games/hlserver-psychostats/Makefile
deleted file mode 100644
index e9c829f5f963..000000000000
--- a/games/hlserver-psychostats/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-# New ports collection makefile for: Half Life Psychostats
-# Date created: Sun Oct 14 14:34:20 CEST 2001
-# Whom: Martin Matuska <mm@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= psychostats
-PORTVERSION= 1.9.1
-PORTREVISION= 1
-CATEGORIES= games www
-MASTER_SITES= ftp://ftp.thaiguy.net/ \
- http://www.psychostats.com/dl/ \
- http://www.realityslap.com/downloads/ \
- http://fratello-server.com/downloads/serveur/ \
- http://mirrors.voyager.net/games/halflife/stats/psychostats/
-DISTNAME= ${PORTNAME}${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Popular player statistics generator for Half-Life (cs/dod)
-
-USE_PERL5_BUILD=yes
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-# files which should be installed with executable perms
-EXECUTABLES= stats.pl install.pl
-
-DEPRECATED= outdated, unmaintained
-EXPIRATION_DATE=2007-04-10
-
-post-patch:
-.for files in ${EXECUTABLES}
- @${PERL} -pi -e 's|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/${files}
-.endfor
- @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|; \
- s|%%LOCALBASE%%|${LOCALBASE}|; \
- s|%%HLDSDIR%%|${HLDSDIR}|' \
- ${WRKSRC}/stats.cfg
-
-slaveport-post-install:
-.for files in ${EXECUTABLES}
- @${CHMOD} u+x ${PREFIX}${HLDSDIR}${DISTNAME}/${files}
-.endfor
-
-HALFLIFE_PORT_MASTER= ${.CURDIR}/../hlserver-flf
-
-.include "${HALFLIFE_PORT_MASTER}/Makefile"