aboutsummaryrefslogtreecommitdiff
path: root/games/iagno/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/iagno/Makefile')
-rw-r--r--games/iagno/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/iagno/Makefile b/games/iagno/Makefile
index ad997168b77e..ae1abab18342 100644
--- a/games/iagno/Makefile
+++ b/games/iagno/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= iagno
-PORTVERSION= 3.18.2
+PORTVERSION= 3.22.0
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -10,18 +10,23 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Iagno
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= vala:lang/vala \
- itstool:textproc/itstool
-LIB_DEPENDS= libcanberra-gtk3.so:audio/libcanberra-gtk3
+ itstool:textproc/itstool \
+ appstream-util:devel/appstream-glib
+
+LIB_DEPENDS= libcanberra.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome pathfix pkgconfig tar:xz
-USE_GNOME= gtk30 intlhack librsvg2 libxml2:build
+USES= gettext gmake gnome localbase pathfix pkgconfig tar:xz
+USE_GNOME= cairo gtk30 intlhack librsvg2 libxml2:build
+USE_XORG= x11
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.iagno.gschema.xml