aboutsummaryrefslogtreecommitdiff
path: root/games/ioquake3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/ioquake3/Makefile')
-rw-r--r--games/ioquake3/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index c2f42bfbbec3..cb37008aa1c1 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -19,8 +19,10 @@ USE_BZIP2= yes
USE_GMAKE= yes
OPTIONS= CLIENT "Build client" on \
+ CELLSHADING "Enable Cell Shading effect" off \
GAMELIBS "Build game libraries (when not mandatory)" off \
DEDICATED "Build dedicated server" on \
+ MP3 "Enable MP3 support" off \
OPENAL "Enable OpenAL (3D sound) support" off \
OPENAL_DLOPEN "Enable dynamic loading of OpenAL" off \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
@@ -29,7 +31,7 @@ OPTIONS= CLIENT "Build client" on \
SMP "Build SMP (threaded) client" on \
VORBIS "Enable Ogg Vorbis codec support" off
-MAKE_ENV+= DEFAULT_BASEDIR="${Q3DIR}" LIBDIR="${LIBDIR}" \
+MAKE_ENV= DEFAULT_BASEDIR="${Q3DIR}" LIBDIR="${LIBDIR}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
@@ -53,6 +55,10 @@ HAVE_VM_COMPILED= yes
MAKE_ENV+= HAVE_VM_COMPILED=true
.endif
+.if defined(WITH_CELLSHADING)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cellshading
+.endif
+
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
# OpenAL
. if defined(WITH_OPENAL)
@@ -104,6 +110,12 @@ PLIST_SUB+= GAMELIBS=""
PLIST_SUB+= GAMELIBS="@comment "
.endif
+.if defined(WITH_MP3)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mp3
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+MAKE_ENV+= USE_CODEC_MP3=1
+.endif
+
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
MAKE_ENV+= USE_OPTIMIZED_CFLAGS=1
.endif