aboutsummaryrefslogtreecommitdiff
path: root/games/jools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/jools/Makefile')
-rw-r--r--games/jools/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/jools/Makefile b/games/jools/Makefile
new file mode 100644
index 000000000000..37ca002b1d48
--- /dev/null
+++ b/games/jools/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: jools
+# Date created: 6 June 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= jools
+PORTVERSION= 0.10
+CATEGORIES= games
+MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/jools/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Addictive jewel-swapping puzzle game
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+USE_PYTHON= yes
+
+do-build:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} ${WRKSRC}/setup.py install --prefix=${PREFIX}
+
+.include <bsd.port.mk>