aboutsummaryrefslogtreecommitdiff
path: root/games/kdiamond/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/kdiamond/Makefile')
-rw-r--r--games/kdiamond/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/games/kdiamond/Makefile b/games/kdiamond/Makefile
new file mode 100644
index 000000000000..6bb7a485a4ae
--- /dev/null
+++ b/games/kdiamond/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= kdiamond
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>