aboutsummaryrefslogtreecommitdiff
path: root/games/kpat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/kpat/Makefile')
-rw-r--r--games/kpat/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/kpat/Makefile b/games/kpat/Makefile
new file mode 100644
index 000000000000..1129d679599a
--- /dev/null
+++ b/games/kpat/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= kpat
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4 sharedmime
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
+ ${WRKSRC}/mimetypes/CMakeLists.txt
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>