aboutsummaryrefslogtreecommitdiff
path: root/games/lgeneral/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lgeneral/Makefile')
-rw-r--r--games/lgeneral/Makefile40
1 files changed, 33 insertions, 7 deletions
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index 331d16a08fce..5b85b4c31f57 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -6,22 +6,48 @@
#
PORTNAME= lgeneral
-PORTVERSION= 1.1.1
-PORTREVISION= 7
+PORTVERSION= 1.2
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-engine/1.1
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A turn-based strategy engine inspired by Panzer General
USE_SDL= sdl
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-.ifndef (WITHOUT_SOUND)
-USE_SDL= mixer
-.else
+MAN1= lgc-pg.1
+MAN6= lgeneral.6
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if defined(WITHOUT_SOUND)
CONFIGURE_ARGS+=--disable-sound
+.else
+USE_SDL+= mixer
.endif
-GNU_CONFIGURE= yes
+.if defined(WITHOUT_NLS)
+CONFIGURE_ENV+= am_cv_func_iconv=no
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-g -Wall|-Wall| ; \
+ s|/games||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/icons|/pixmaps|' ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}
+.endif
.include <bsd.port.mk>