aboutsummaryrefslogtreecommitdiff
path: root/games/lgeneral/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lgeneral/Makefile')
-rw-r--r--games/lgeneral/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/lgeneral/Makefile b/games/lgeneral/Makefile
index bb6628793b67..b85ca201d370 100644
--- a/games/lgeneral/Makefile
+++ b/games/lgeneral/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lgeneral
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= lgeneral
@@ -19,6 +20,12 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+.ifndef (WITHOUT_SOUND)
+LIB_DEPENDS+= SDL_mixer:${PORTSDIR}/audio/sdl_mixer
+.else
+CONFIGURE_ARGS+=--disable-sound
+.endif
+
GNU_CONFIGURE= yes
.include <bsd.port.mk>