aboutsummaryrefslogtreecommitdiff
path: root/games/libfov/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/libfov/Makefile')
-rw-r--r--games/libfov/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/games/libfov/Makefile b/games/libfov/Makefile
index f36ca56ff892..a77736090670 100644
--- a/games/libfov/Makefile
+++ b/games/libfov/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= libfov
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= games devel
-MASTER_SITES= SFE/libfov
+MASTER_SITES= http://libfov.googlecode.com/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= C library for calculating fields of view on low resolution rasters
-WRKSRC= ${WRKDIR}/${DISTNAME}/fov
+USE_GNOME= gnomehack pkgconfig
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= ac_cv_prog_doxygen=no ac_cv_path_SDL_CONFIG=no
USE_LDCONFIG= yes
post-extract:
- @${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile
+ @${CHMOD} ${BINMODE} ${WRKSRC}/install-sh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^AM_CFLAGS|#AM_CFLAGS|g'
.include <bsd.port.mk>