aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-snes9x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/libretro-snes9x/Makefile')
-rw-r--r--games/libretro-snes9x/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/libretro-snes9x/Makefile b/games/libretro-snes9x/Makefile
new file mode 100644
index 000000000000..95eed77cc91d
--- /dev/null
+++ b/games/libretro-snes9x/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= libretro-snes9x
+PORTVERSION= 0.20200313
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Snes9x - Portable Super Nintendo emulator
+
+LICENSE= PS
+LICENSE_NAME= PS
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+BROKEN_FreeBSD_11= linker error: unrecognized option '-plugin'
+
+USES= compiler:c++11-lib gmake
+USE_LDCONFIG= yes
+
+NO_CDROM= Commercial users must seek permission from copyright holders.
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= snes9x
+GH_TAGNAME= 6db918c
+
+PLIST_FILES= libexec/libretro/snes9x_libretro.so
+
+MAKEFILE= Makefile.freebsd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/libexec/libretro;
+ ${INSTALL_LIB} $$(find ${WRKSRC}/${COREDIR}/ -name "*.so") ${STAGEDIR}/${PREFIX}/libexec/libretro;
+
+.include <bsd.port.mk>