aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-uae/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/libretro-uae/Makefile')
-rw-r--r--games/libretro-uae/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/libretro-uae/Makefile b/games/libretro-uae/Makefile
new file mode 100644
index 000000000000..9f5d7153774b
--- /dev/null
+++ b/games/libretro-uae/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libretro-uae
+PORTVERSION= 0.20200313
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Libretro port of UAE
+
+LICENSE= GPLv2
+
+USES= compiler:c++11-lib gmake gl
+USE_LDCONFIG= yes
+USE_GL= gl
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_TAGNAME= 8333daa
+
+PLIST_FILES= libexec/libretro/puae_libretro.so
+
+post-patch:
+ ${REINPLACE_CMD} 's/" GIT_VERSION/${GH_TAGNAME}"/' ${WRKSRC}/libretro/libretro.c
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/libexec/libretro;
+ ${INSTALL_LIB} $$(find ${WRKSRC}/${COREDIR}/ -name "*.so") ${STAGEDIR}/${PREFIX}/libexec/libretro;
+
+.include <bsd.port.mk>