aboutsummaryrefslogtreecommitdiff
path: root/games/lordsawar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lordsawar/Makefile')
-rw-r--r--games/lordsawar/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index 59bf4c6152ca..d7618ae121a8 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -6,25 +6,31 @@
#
PORTNAME= lordsawar
-PORTVERSION= 0.1.0
+PORTVERSION= 0.1.4
CATEGORIES= games
-MASTER_SITES= http://lordsawar.com/
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= spam@rm-rf.kiev.ua
COMMENT= A Warlords II clone
LIB_DEPENDS= glademm-2.4:${PORTSDIR}/devel/libglademm24 \
- gnet-2.0:${PORTSDIR}/net/gnet2
+ gnet-2.0:${PORTSDIR}/net/gnet2 \
+ uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
USE_GZIP= yes
USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= intltool
USE_SDL= sdl image
OPTIONS= SOUND "Enable sound" on
.include <bsd.port.pre.mk>
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS+=--disable-nls \
+ --with-boost-includedir=${LOCALBASE}/include/
.if !defined(WITHOUT_SOUND)
USE_SDL+= mixer