aboutsummaryrefslogtreecommitdiff
path: root/games/lordsawar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lordsawar/Makefile')
-rw-r--r--games/lordsawar/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
new file mode 100644
index 000000000000..e1fd532e6cd0
--- /dev/null
+++ b/games/lordsawar/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lordsawar
+# Date created: 12 February 2008
+# Whom: spam@rm-rf.kiev.ua
+#
+# $FreeBSD$
+#
+
+PORTNAME= lordsawar
+PORTVERSION= 0.0.8
+CATEGORIES= games
+MASTER_SITES= http://lordsawar.com/
+
+MAINTAINER= spam@rm-rf.kiev.ua
+COMMENT= A Warlords II clone
+
+LIB_DEPENDS= glademm-2.4:${PORTSDIR}/devel/libglademm24
+
+USE_GZIP= yes
+USE_GETTEXT= yes
+USE_SDL= sdl image
+
+OPTIONS= SOUND "Enable sound" on
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS+=--disable-nls
+
+.if !defined(WITHOUT_SOUND)
+USE_SDL+= mixer
+.else
+CONFIGURE_ARGS+=--disable-sound
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.post.mk>