aboutsummaryrefslogtreecommitdiff
path: root/games/madbomber/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/madbomber/Makefile')
-rw-r--r--games/madbomber/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/games/madbomber/Makefile b/games/madbomber/Makefile
index 5b03abf91d84..c2d7d553fd1e 100644
--- a/games/madbomber/Makefile
+++ b/games/madbomber/Makefile
@@ -1,19 +1,15 @@
-# New ports collection makefile for: madbomber
-# Date created: 28 September 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= madbomber
PORTVERSION= 0.2.5
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/madbomber/src/ \
ftp://ftp.billsgames.com/unix/x/madbomber/src/
MAINTAINER= nemysis@gmx.ch
-COMMENT= A clone of Activision's classic Atari 2600 console game "Kaboom!"
+COMMENT= Clone of Activision's classic Atari 2600 console game "Kaboom!"
LICENSE= GPLv2
@@ -22,12 +18,12 @@ USE_SDL= mixer image sdl
CPPFLAGS+= `${SDL_CONFIG} --cflags` -DDATA_PREFIX=\"${DATADIR}/\"
LDFLAGS+= `${SDL_CONFIG} --libs`
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= AUTHORS.txt CHANGES.txt README.txt TODO.txt
+DESKTOP_ENTRIES="Mad Bomber" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
.include <bsd.port.options.mk>
do-build:
@@ -35,24 +31,18 @@ do-build:
${PORTNAME}.c ${LDFLAGS} -lSDL_mixer -lSDL_image
do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-# Data
${MKDIR} ${DATADIR}
.for d in images music sounds
@(cd ${WRKSRC}/data && ${COPYTREE_SHARE} ${d} ${DATADIR})
.endfor
-# Pixmaps
${INSTALL_DATA} ${WRKSRC}/data/images/icon.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>