aboutsummaryrefslogtreecommitdiff
path: root/games/minecraft-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/minecraft-server/Makefile')
-rw-r--r--games/minecraft-server/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/games/minecraft-server/Makefile b/games/minecraft-server/Makefile
index 189e9f72fefc..62629264db24 100644
--- a/games/minecraft-server/Makefile
+++ b/games/minecraft-server/Makefile
@@ -2,6 +2,7 @@
PORTNAME= minecraft-server
PORTVERSION= 1.8.1
+PORTREVISION= 1
CATEGORIES= games java
MASTER_SITES= https://s3.amazonaws.com/Minecraft.Download/versions/${PORTVERSION}/
DISTNAME= minecraft_server.${PORTVERSION}.jar
@@ -11,6 +12,10 @@ EXTRACT_ONLY=
MAINTAINER= freebsd@jonathanprice.org
COMMENT= Dedicated server for the game Minecraft
+OPTIONS_DEFINE= DAEMON
+DAEMON_DESC= Allows controlling via rc.d
+OPTIONS_SUB= yes
+
USERS= mcserver
GROUPS= ${USERS}
@@ -27,6 +32,13 @@ CONFIG_FILES= banned-ips.json \
usercache.json \
whitelist.json
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDAEMON}
+USE_RC_SUBR+= minecraft
+RUN_DEPENDS+= tmux:${PORTSDIR}/sysutils/tmux
+.endif
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${PORTNAME}
${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/${PORTNAME}