aboutsummaryrefslogtreecommitdiff
path: root/games/nethack33/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack33/Makefile')
-rw-r--r--games/nethack33/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 363f74c3bbc0..2a4b2e21cf2d 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -27,8 +27,6 @@ MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}"
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
-.include <bsd.port.pre.mk>
-
.if defined(WITH_GNOME_GRAPHICS)
CATEGORIES= games gnome
PKGNAMESUFFIX= -gnome
@@ -36,9 +34,6 @@ LIB_DEPENDS+= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_GNOME= yes
GRAPHICS= GNOME_GRAPHICS
.elif defined(WITH_QT_GRAPHICS)
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not build"
-.endif
PKGNAMESUFFIX= -qt
USE_QT_VER= 2
MAKE_ENV+= QTCPPFLAGS="${QTCPPFLAGS}" QTCFGLIBS="${QTCFGLIBS}" \
@@ -51,6 +46,12 @@ USE_XPM= yes
GRAPHICS= X11_GRAPHICS
.endif
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QT_GRAPHICS) && ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
pre-everything::
.if defined(WITH_GNOME_GRAPHICS) || defined(WITH_QT_GRAPHICS) \
|| defined(WITH_TTY_GRAPHICS) || defined(WITHOUT_X11)