aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34-qt/files/patch-sys:unix:Makefile.top
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack34-qt/files/patch-sys:unix:Makefile.top')
-rw-r--r--games/nethack34-qt/files/patch-sys:unix:Makefile.top44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/nethack34-qt/files/patch-sys:unix:Makefile.top b/games/nethack34-qt/files/patch-sys:unix:Makefile.top
new file mode 100644
index 000000000000..fb4a9021dd90
--- /dev/null
+++ b/games/nethack34-qt/files/patch-sys:unix:Makefile.top
@@ -0,0 +1,44 @@
+--- sys/unix/Makefile.top.orig Tue Jul 4 09:42:05 2000
++++ sys/unix/Makefile.top Sat Aug 11 11:21:15 2001
+@@ -14,18 +14,17 @@
+ # MAKE = make
+
+ # make NetHack
+-PREFIX = /usr
+ GAME = nethack
+ # GAME = nethack.prg
+ GAMEUID = games
+-GAMEGRP = bin
++GAMEGRP = games
+
+ # Permissions - some places use setgid instead of setuid, for instance
+ # See also the option "SECURE" in include/config.h
+-GAMEPERM = 04755
+-FILEPERM = 0644
++GAMEPERM = 02755
++FILEPERM = 0664
+ EXEPERM = 0755
+-DIRPERM = 0755
++DIRPERM = 0775
+
+ # GAMEDIR also appears in config.h as "HACKDIR".
+ # VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
+@@ -35,14 +34,14 @@
+ # therefore there should not be anything in GAMEDIR that you want to keep
+ # (if there is, you'll have to do the installation by hand or modify the
+ # instructions)
+-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
++GAMEDIR = $(PREFIX)/lib/$(GAME)
+ VARDIR = $(GAMEDIR)
+-SHELLDIR = $(PREFIX)/games
++SHELLDIR = $(PREFIX)/bin
+
+ # per discussion in Install.X11 and Install.Qt
+-VARDATND =
++# VARDATND =
+ # VARDATND = x11tiles pet_mark.xbm
+-# VARDATND = x11tiles pet_mark.xbm rip.xpm
++VARDATND = x11tiles pet_mark.xbm rip.xpm
+ # for Atari/Gem
+ # VARDATND = nh16.img title.img GEM_RSC.RSC
+ # for BeOS