aboutsummaryrefslogtreecommitdiff
path: root/games/numptyphysics-npcomplete/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/numptyphysics-npcomplete/Makefile')
-rw-r--r--games/numptyphysics-npcomplete/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/numptyphysics-npcomplete/Makefile b/games/numptyphysics-npcomplete/Makefile
new file mode 100644
index 000000000000..5aea5a2df952
--- /dev/null
+++ b/games/numptyphysics-npcomplete/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: numptyphysics-npcomplete
+# Date created: 04 Jan 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= npcomplete
+PORTVERSION= 0.0.r20090116
+CATEGORIES= games
+MASTER_SITES= http://mirror.amdmi3.ru/
+PKGNAMEPREFIX= numptyphysics-
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Level pack for Numpty Physics
+
+RUN_DEPENDS= numptyphysics:${PORTSDIR}/games/numptyphysics
+
+USE_BZIP2= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/npcomplete
+DATADIR= ${PREFIX}/share/numptyphysics
+
+post-extract:
+# this level will crash the game
+ @${RM} -f "${WRKSRC}/L02_bridge Gaps tut.nph"
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.nph ${DATADIR}
+
+.include <bsd.port.mk>