aboutsummaryrefslogtreecommitdiff
path: root/games/oolite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/oolite/Makefile')
-rw-r--r--games/oolite/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/games/oolite/Makefile b/games/oolite/Makefile
new file mode 100644
index 000000000000..51d10bdc02b0
--- /dev/null
+++ b/games/oolite/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: oolite
+# Date created: 04 Oct 2005
+# Whom: Andriy Gapon <avg@icyb.net.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oolite
+PORTVERSION= 1.55
+CATEGORIES= games
+MASTER_SITES= http://download.berlios.de/oolite-linux/ \
+ ftp://ftp.alioth.net/oolite/
+DISTFILES= ${PORTNAME}-src-${PORTVERSION}-1${EXTRACT_SUFX} ${PORTNAME}-data-${PORTVERSION}-1${EXTRACT_SUFX}
+
+MAINTAINER= avg@icyb.net.ua
+COMMENT= Trade and combat space simulator, clone of Elite
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-src
+PREFIX= ${LOCALBASE}/GNUstep
+NO_MTREE= yes
+USE_REINPLACE= yes
+USE_SDL= mixer image gfx
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_GUI= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-extract:
+ ${MV} ${WRKDIR}/${PORTNAME}-data/Resources ${WRKSRC}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s#sdl-config#${SDL_CONFIG}#g" ${WRKSRC}/${MAKEFILE}
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>