aboutsummaryrefslogtreecommitdiff
path: root/games/openglad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/openglad/Makefile')
-rw-r--r--games/openglad/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/openglad/Makefile b/games/openglad/Makefile
new file mode 100644
index 000000000000..dca33c57ea6e
--- /dev/null
+++ b/games/openglad/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: openglad
+# Date created: 13 May 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openglad
+PORTVERSION= 0.98
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= snowstorm
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= SDL port of an old DOS game called Gladiator
+
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+ SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${X11BASE}/include"
+PLIST_SUB= DOCDIR=share/doc/${PORTNAME}
+
+post-configure:
+ ${REINPLACE_CMD} -e 's|/path/to/data/dir|${LOCALBASE}/share/openglad|g' \
+ ${WRKSRC}/openglad.cfg
+
+.include <bsd.port.mk>