aboutsummaryrefslogtreecommitdiff
path: root/games/p5-Games-Bingo-Print/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/p5-Games-Bingo-Print/Makefile')
-rw-r--r--games/p5-Games-Bingo-Print/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
index e11addea8bc7..af9c0ad3d5ed 100644
--- a/games/p5-Games-Bingo-Print/Makefile
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -22,18 +22,17 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN1= bingo_print.pl.1
-MAN3= Games::Bingo::Print.3
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= bingo_print.pl
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingo_print.pl ${EXAMPLESDIR}
-.endif
-
-test:
- @cd ${WRKSRC}; make test
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingo_print.pl ${STAGEDIR}${EXAMPLESDIR}
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} -s test
.include <bsd.port.mk>