aboutsummaryrefslogtreecommitdiff
path: root/games/pengpong/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pengpong/Makefile')
-rw-r--r--games/pengpong/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
new file mode 100644
index 000000000000..d1db3c0dcd35
--- /dev/null
+++ b/games/pengpong/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pengpong
+# Date created: Fri Aug 24 18:21:25 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pengpong
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pat@databits.net
+
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+NO_WRKSUBDIR= yes
+MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/pengpong ${PREFIX}/bin
+
+.include <bsd.port.mk>