aboutsummaryrefslogtreecommitdiff
path: root/games/pengupop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pengupop/Makefile')
-rw-r--r--games/pengupop/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/pengupop/Makefile b/games/pengupop/Makefile
new file mode 100644
index 000000000000..b0aa68f73456
--- /dev/null
+++ b/games/pengupop/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pengupop
+# Date created: 14 Jun 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pengupop
+PORTVERSION= 2.0.2
+CATEGORIES= games
+MASTER_SITES= http://www.junoplay.com/files/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Online multiplayer clone of Bust a Move
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GCC= 3.4+
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ LDFLAGS="`${SDL_CONFIG} --libs`"
+
+PLIST_FILES= bin/pengupop
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build on FreeBSD 4.x: lack of swprintf
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>