aboutsummaryrefslogtreecommitdiff
path: root/games/phalanx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/phalanx/Makefile')
-rw-r--r--games/phalanx/Makefile38
1 files changed, 17 insertions, 21 deletions
diff --git a/games/phalanx/Makefile b/games/phalanx/Makefile
index 1099c3ec1c86..218b0948779e 100644
--- a/games/phalanx/Makefile
+++ b/games/phalanx/Makefile
@@ -1,37 +1,33 @@
# New ports collection makefile for: phalanx
-# Version required: 21
+# Version required: 22
# Date created: 2 May 1999
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
-DISTNAME= phalanx-21
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- ftp://ftp.math.muni.cz/pub/math/people/Dobes/
-MASTER_SITE_SUBDIR= games/strategy
+DISTNAME= phalanx-22
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.math.muni.cz/pub/math/people/Dobes/ \
+ http://www.crosswinds.net/~dobes/phalanx/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-WRKSRC= ${WRKDIR}/Phalanx-XXI
-USE_GMAKE= yes
-ALL_TARGET=
-MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/Phalanx-XXII
+USE_GMAKE= yes
+ALL_TARGET= # empty
+MAKEFILE= makefile
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/phalanx ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/pbook.phalanx ${PREFIX}/share/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/sbook.phalanx ${PREFIX}/share/phalanx
-
-post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/phalanx ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/phalanx
+ ${INSTALL_DATA} ${WRKSRC}/pbook.phalanx ${PREFIX}/share/phalanx
+ ${INSTALL_DATA} ${WRKSRC}/sbook.phalanx ${PREFIX}/share/phalanx
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/phalanx
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/phalanx
+ @${MKDIR} ${PREFIX}/share/doc/phalanx
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/phalanx
.endif
.include <bsd.port.mk>