aboutsummaryrefslogtreecommitdiff
path: root/games/pioneers/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pioneers/Makefile')
-rw-r--r--games/pioneers/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index c0d6bfe6abbe..db28e83963bd 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pioneers
-PORTVERSION= 0.9.23
+PORTVERSION= 0.9.33
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= pio
@@ -16,13 +16,22 @@ COMMENT= An Internet playable version of the Settlers of Catan for GNOME/GTK
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix gtk20 libgnome
+USE_GNOME= gnomehack gnomeprefix gtk20
USE_LIBTOOL_VER=15
-INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
MAN6= pioneers.6 pioneers-server-gtk.6 pioneers-server-console.6 \
pioneersai.6 pioneers-meta-server.6
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if exists(${X11BASE}/bin/scrollkeeper-config)
+USE_GNOME+= libgnome
+INSTALLS_OMF= yes
+PLIST_SUB+= LIBGNOME=""
+.else
+PLIST_SUB+= LIBGNOME="@comment "
+.endif
+
+.include <bsd.port.post.mk>