aboutsummaryrefslogtreecommitdiff
path: root/games/poker-engine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/poker-engine/Makefile')
-rw-r--r--games/poker-engine/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index d39083cc89f8..881b035708d3 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -14,15 +14,16 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:net/rsync \
- ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval \
- ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2 \
- ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt
+ ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt@${FLAVOR}
RUN_DEPENDS= ${LOCALBASE}/bin/rsync:net/rsync \
- ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval \
- ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2 \
- ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt
+ ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt@${FLAVOR}
USES= gettext gmake pathfix pkgconfig python:2
+USE_PYTHON= flavors
GNU_CONFIGURE= yes
test: