aboutsummaryrefslogtreecommitdiff
path: root/games/pouetchess/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pouetchess/Makefile')
-rw-r--r--games/pouetchess/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/pouetchess/Makefile b/games/pouetchess/Makefile
index 36ac2832f647..974d18fdefd2 100644
--- a/games/pouetchess/Makefile
+++ b/games/pouetchess/Makefile
@@ -10,11 +10,15 @@ DISTNAME= pouetChess_0.11_src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 3D chess game
-USE_SDL= sdl image
-USE_GL= gl
+LICENSE= GPLv2 # from sourceforge page
+
USES= dos2unix gmake
+USE_SDL= sdl image
+USE_GL= gl glu
DOS2UNIX_GLOB= *.cpp *.h Makefile config.ini
+CXXFLAGS+= -Wno-reserved-user-defined-literal
+
WRKSRC= ${WRKDIR}/pouetChess_0.11
PORTDATA= *
@@ -40,6 +44,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/pouetChess ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/bin/config.ini ${STAGEDIR}${PREFIX}/etc/pouetChess.conf.sample
- cd ${WRKSRC}/bin/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
+ @cd ${WRKSRC}/bin/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>