aboutsummaryrefslogtreecommitdiff
path: root/games/pushover/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pushover/Makefile')
-rw-r--r--games/pushover/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/games/pushover/Makefile b/games/pushover/Makefile
index 1e679f2b964b..19fbbc3d2bef 100644
--- a/games/pushover/Makefile
+++ b/games/pushover/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= pushover
-PORTVERSION= 0.0.1
-PORTREVISION= 2
+PORTVERSION= 0.0.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Pushover/${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Pushover Screenshot Pushover a lot of dominos
+COMMENT= A puzzle game where the goal is to push over all dominoes
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
@@ -20,9 +19,19 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl mixer ttf
USE_LUA= 5.1
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
PORTDOCS= *
+DESKTOP_ENTRIES="Pushover" \
+ "Push over all dominoes" \
+ "" \
+ "pushover" \
+ "Game;LogicGame;" \
+ false
+
post-patch:
@${REINPLACE_CMD} -e '/PKG_CONFIG/ s|lua5.1|lua-5.1|' \
${WRKSRC}/configure