aboutsummaryrefslogtreecommitdiff
path: root/games/py-mnemosyne/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/py-mnemosyne/Makefile')
-rw-r--r--games/py-mnemosyne/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/games/py-mnemosyne/Makefile b/games/py-mnemosyne/Makefile
index aa924e117614..34451017a29c 100644
--- a/games/py-mnemosyne/Makefile
+++ b/games/py-mnemosyne/Makefile
@@ -7,28 +7,27 @@
#
PORTNAME= mnemosyne
-PORTVERSION= 1.1.1
+PORTVERSION= 1.2.1
CATEGORIES= games python
-MASTER_SITES= SF/${PORTNAME}-proj/OldFiles
+MASTER_SITES= SF/${PORTNAME}-proj/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= mnemosyne-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Flash-card tool which optimises your learning process
+RUN_DEPENDS= py*-game>=0:${PORTSDIR}/devel/py-game \
+ py*-qt>=0:${PORTSDIR}/x11-toolkits/py-qt \
+ ${PYXML}
+
USE_PYTHON= 2.4+
USE_PYDISTUTILS= easy_install
PYEASYINSTALL_EGG= Mnemosyne-${PORTVERSION}-${PYTHON_VERSION:S/thon//}${PYEASYINSTALL_OSARCH}.egg
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game \
- py*-xml>=0:${PORTSDIR}/textproc/py-xml \
- py*-qt>=0:${PORTSDIR}/x11-toolkits/py-qt
-
post-install:
- @${INSTALL} -d ${PREFIX}/share/applications
- @${INSTALL_DATA} ${WRKSRC}/mnemosyne.desktop ${PREFIX}/share/applications/
- @${INSTALL} -d ${PREFIX}/share/icons
- @${INSTALL_DATA} ${WRKSRC}/pixmaps/mnemosyne.png ${PREFIX}/share/icons/
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+ @${MKDIR} ${PREFIX}/share/icons
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/${PORTNAME}.png ${PREFIX}/share/icons
.include <bsd.port.mk>