aboutsummaryrefslogtreecommitdiff
path: root/games/qccx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/qccx/Makefile')
-rw-r--r--games/qccx/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/games/qccx/Makefile b/games/qccx/Makefile
index 90c7110b2549..6c9d60529c21 100644
--- a/games/qccx/Makefile
+++ b/games/qccx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: QCCX
-# Date created: 18 Jan 2005
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= qccx
PORTVERSION= 1.0.0
@@ -13,22 +9,26 @@ MASTER_SITES= http://www.quakewiki.net/archives/qccx/ \
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= A very fast optimizing QuakeC compiler
+COMMENT= Very fast optimizing QuakeC compiler
LICENSE= GPLv2
USE_ZIP= yes
USE_DOS2UNIX= pr_comp.cpp qcc.cpp ${PORTDOCS}
+MAKEFILE= ${FILESDIR}/Makefile
NO_WRKSUBDIR= yes
-MAKEFILE= ${FILESDIR}/Makefile
PORTDOCS= manual.txt readme.txt
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.qc ${WRKSRC}/progs.src ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif