aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/quakeforge/files')
-rw-r--r--games/quakeforge/files/patch-aa11
-rw-r--r--games/quakeforge/files/patch-ab19
-rw-r--r--games/quakeforge/files/patch-ac10
-rw-r--r--games/quakeforge/files/patch-ad11
-rw-r--r--games/quakeforge/files/patch-ae13
-rw-r--r--games/quakeforge/files/patch-af11
-rw-r--r--games/quakeforge/files/patch-ag11
-rw-r--r--games/quakeforge/files/patch-configure26
-rw-r--r--games/quakeforge/files/patch-ltmain.sh11
-rw-r--r--games/quakeforge/files/patch-qfbsp27
-rw-r--r--games/quakeforge/files/patch-zpak18
11 files changed, 37 insertions, 131 deletions
diff --git a/games/quakeforge/files/patch-aa b/games/quakeforge/files/patch-aa
deleted file mode 100644
index 0d8d5e12344a..000000000000
--- a/games/quakeforge/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/audio/renderer/Makefile.in.orig Wed Nov 13 20:21:33 2002
-+++ libs/audio/renderer/Makefile.in Wed Nov 13 20:22:16 2002
-@@ -206,7 +206,7 @@
- AUTOMAKE_OPTIONS = foreign
-
- AM_CFLAGS = @PREFER_PIC@
--INCLUDES = -I$(top_srcdir)/include
-+INCLUDES = -I$(top_srcdir)/include $(VORBIS_CFLAGS) $(OGG_CFLAGS)
- plugin_version = 1:0:0
-
- plugin_PROGRAMS = @SND_REND_TARGETS@
diff --git a/games/quakeforge/files/patch-ab b/games/quakeforge/files/patch-ab
deleted file mode 100644
index 57a656c45c55..000000000000
--- a/games/quakeforge/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- libs/util/quakeio.c.orig 16 Oct 2002 04:59:34 -0000 1.18
-+++ libs/util/quakeio.c 24 Oct 2002 22:36:15 -0000 1.19
-@@ -425,8 +425,14 @@
- res = fseek (file->file, offset, whence);
- break;
- case SEEK_END:
-- res = fseek (file->file,
-- file->start + file->size - offset, SEEK_SET);
-+ if (file->size == -1) {
-+ // we don't know the size (due to writing) so punt and
-+ // pass on the request as-is
-+ res = fseek (file->file, offset, SEEK_END);
-+ } else {
-+ res = fseek (file->file,
-+ file->start + file->size - offset, SEEK_SET);
-+ }
- break;
- default:
- errno = EINVAL;
diff --git a/games/quakeforge/files/patch-ac b/games/quakeforge/files/patch-ac
deleted file mode 100644
index 42773123b4e4..000000000000
--- a/games/quakeforge/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- libs/audio/renderer/Makefile.am.orig Wed Nov 13 21:30:38 2002
-+++ libs/audio/renderer/Makefile.am Wed Nov 13 21:30:47 2002
-@@ -1,6 +1,6 @@
- AUTOMAKE_OPTIONS= foreign
-
--AM_CFLAGS= @PREFER_PIC@
-+AM_CFLAGS= @PREFER_PIC@ @VORBIS_CFLAGS@
- INCLUDES= -I$(top_srcdir)/include
- plugin_version= 1:0:0
- plugin_ldflags= @plugin_ldflags@
diff --git a/games/quakeforge/files/patch-ad b/games/quakeforge/files/patch-ad
deleted file mode 100644
index 83da6b11792a..000000000000
--- a/games/quakeforge/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/audio/targets/snd_oss.c.orig Wed Nov 13 22:21:14 2002
-+++ libs/audio/targets/snd_oss.c Wed Nov 13 22:19:08 2002
-@@ -252,7 +252,7 @@
- if (mmaped_io) { // memory map the dma buffer
- shm->buffer = (unsigned char *) mmap
- (NULL, info.fragstotal * info.fragsize,
--#if (defined(BSD)) // workaround for BSD OSS quirk
-+#if (defined(__FreeBSD__) && (__FreeBSD_version < 500000)) // workaround for BSD OSS quirk
- PROT_READ | PROT_WRITE,
- #else
- PROT_WRITE,
diff --git a/games/quakeforge/files/patch-ae b/games/quakeforge/files/patch-ae
deleted file mode 100644
index 3ebeacd18bb0..000000000000
--- a/games/quakeforge/files/patch-ae
+++ /dev/null
@@ -1,13 +0,0 @@
---- libs/video/targets/vid_svgalib.c.orig Mon Jan 13 20:14:39 2003
-+++ libs/video/targets/vid_svgalib.c Mon Jan 13 20:24:38 2003
-@@ -641,4 +641,10 @@
- {
- asm ("outb %b0, %w1" : :"a"(val), "d"(port));
- }
-+#elif defined(__FreeBSD__)
-+static inline void
-+outb (unsigned char value, unsigned short port)
-+{
-+ __asm__ __volatile__ ("outb %b0,%w1"::"a" (value), "d" (port));
-+}
- #endif
diff --git a/games/quakeforge/files/patch-af b/games/quakeforge/files/patch-af
deleted file mode 100644
index 2c7b93fadc46..000000000000
--- a/games/quakeforge/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Jan 6 17:45:41 2003
-+++ configure Mon Jan 6 17:46:42 2003
-@@ -15588,7 +15588,7 @@
- no_sdl=yes
- else
- SDL_CFLAGS=`$SDL_CONFIG $sdlconf_args --cflags`
-- SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs`
-+ SDL_LIBS=`$SDL_CONFIG $sdlconf_args --libs | sed 's/-lc_r/-pthread/'`
-
- sdl_major_version=`$SDL_CONFIG $sdl_args --version | \
- sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
diff --git a/games/quakeforge/files/patch-ag b/games/quakeforge/files/patch-ag
deleted file mode 100644
index e265565c2855..000000000000
--- a/games/quakeforge/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./qw/source/teamplay.c.orig Fri Jan 31 20:27:27 2003
-+++ ./qw/source/teamplay.c Fri Jan 31 20:26:48 2003
-@@ -493,7 +493,7 @@
- {
- int i;
-
-- for (i = 0; f_replies[i].name; i++)
-+ for (i = 0; i < sizeof(f_replies) / sizeof(f_replies[0]); i++)
- f_replies[i].lasttime = realtime - cl_freply->value;
- return;
- }
diff --git a/games/quakeforge/files/patch-configure b/games/quakeforge/files/patch-configure
new file mode 100644
index 000000000000..587800682134
--- /dev/null
+++ b/games/quakeforge/files/patch-configure
@@ -0,0 +1,26 @@
+--- configure.orig Sun Jul 27 13:19:51 2003
++++ configure Sun Jul 27 13:41:57 2003
+@@ -2042,10 +2042,10 @@
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
+-if test ${CFLAGS-unset} = unset; then
++if test "${CFLAGS-unset}" = unset; then
+ CFLAGS=""
+ fi
+-if test ${AR-unset} = unset; then
++if test "${AR-unset}" = unset; then
+ AR="ar"
+ fi
+ export AR
+@@ -8333,6 +8333,9 @@
+ else
+ CPP_NAME="cpp %d -o %o %i"
+ case "$target_os" in
++ *freebsd*)
++ CPP_NAME="cpp %d %i %o"
++ ;;
+ *bsd*)
+ touch conftest.c
+ CPP_NAME="`(f=\`$CC -v -E -Dfoo conftest.c -o conftest.i 2>&1 | grep -e -Dfoo\`; set $f; echo "$1")` %d %i %o"
+
diff --git a/games/quakeforge/files/patch-ltmain.sh b/games/quakeforge/files/patch-ltmain.sh
new file mode 100644
index 000000000000..70b61a47376a
--- /dev/null
+++ b/games/quakeforge/files/patch-ltmain.sh
@@ -0,0 +1,11 @@
+--- ltmain.sh.orig Sun Jul 27 16:09:51 2003
++++ ltmain.sh Sun Jul 27 16:10:01 2003
+@@ -1052,7 +1052,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
diff --git a/games/quakeforge/files/patch-qfbsp b/games/quakeforge/files/patch-qfbsp
deleted file mode 100644
index 34a84541f324..000000000000
--- a/games/quakeforge/files/patch-qfbsp
+++ /dev/null
@@ -1,27 +0,0 @@
---- tools/qfbsp/source/qfbsp.c.orig Wed Jun 25 18:33:19 2003
-+++ tools/qfbsp/source/qfbsp.c Wed Jun 25 18:45:55 2003
-@@ -30,6 +30,9 @@
- # include <strings.h>
- #endif
- #include <stdlib.h>
-+#include <sys/types.h>
-+#include <sys/wait.h>
-+#include <unistd.h>
-
- #include "QF/quakefs.h"
- #include "QF/sys.h"
-@@ -748,12 +751,12 @@
- if (!fork ()) {
- hullnum = 1;
- options.verbosity = 0;
-- drawflag = false;
-+ options.drawflag = false;
- sprintf (argv0, "HUL%i", hullnum);
- } else if (!fork ()) {
- hullnum = 2;
- options.verbosity = 0;
-- drawflag = false;
-+ options.drawflag = false;
- sprintf (argv0, "HUL%i", hullnum);
- }
- CreateSingleHull ();
diff --git a/games/quakeforge/files/patch-zpak b/games/quakeforge/files/patch-zpak
deleted file mode 100644
index cd078b0c2c47..000000000000
--- a/games/quakeforge/files/patch-zpak
+++ /dev/null
@@ -1,18 +0,0 @@
---- tools/zpak.orig Sat Mar 15 23:32:09 2003
-+++ tools/zpak Sat Mar 15 23:58:52 2003
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#!/bin/sh
- # create pak files with gzipped internals
-
- if [ $# -eq 0 ]; then
-@@ -18,7 +18,7 @@
-
- # cosmetic (gzip preserves timestamps.. could come in handy)
- find * -type f \
-- -exec touch {} -r ${pakfile} \;
-+ -exec touch -r ${pakfile} {} \;
-
- find * -type f \
- ! -name '*.gz' ! -name '*.jpg' ! -name '*.ogg' ! -name '*.png' \
-