aboutsummaryrefslogtreecommitdiff
path: root/games/quakeforge/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/quakeforge/files')
-rw-r--r--games/quakeforge/files/patch-configure13
-rw-r--r--games/quakeforge/files/patch-libs__video__renderer__Makefile.in11
2 files changed, 22 insertions, 2 deletions
diff --git a/games/quakeforge/files/patch-configure b/games/quakeforge/files/patch-configure
index d4b93aa52721..dc4856f54304 100644
--- a/games/quakeforge/files/patch-configure
+++ b/games/quakeforge/files/patch-configure
@@ -1,5 +1,5 @@
---- ./configure.orig Sun May 2 17:53:17 2004
-+++ ./configure Sun Dec 17 15:50:06 2006
+--- configure.orig Sun May 2 17:53:17 2004
++++ configure Fri Dec 29 17:54:22 2006
@@ -22733,7 +22733,7 @@
int
main ()
@@ -9,3 +9,12 @@
;
return 0;
}
+@@ -32304,7 +32304,7 @@
+
+
+ if test "x$BUILD_SW" = xyes; then
+- VID_REND_NOINST_TARGETS="$VID_REND_NOINST_TARGETS libQFrenderer_sw.la"
++ VID_REND_TARGETS="$VID_REND_TARGETS libQFrenderer_sw.la"
+ VID_MODEL_TARGETS="$VID_MODEL_TARGETS libQFmodels_sw.la"
+ fi
+ if test "x$BUILD_SW32" = xyes; then
diff --git a/games/quakeforge/files/patch-libs__video__renderer__Makefile.in b/games/quakeforge/files/patch-libs__video__renderer__Makefile.in
new file mode 100644
index 000000000000..3ab3795ec713
--- /dev/null
+++ b/games/quakeforge/files/patch-libs__video__renderer__Makefile.in
@@ -0,0 +1,11 @@
+--- ./libs/video/renderer/Makefile.in.orig Sun May 2 17:52:09 2004
++++ ./libs/video/renderer/Makefile.in Fri Dec 29 17:41:47 2006
+@@ -409,7 +409,7 @@
+ libQFrenderer_gl_la_LIBADD = gl/libgl.la
+ libQFrenderer_gl_la_SOURCES = $(common_sources)
+ libQFrenderer_gl_la_DEPENDENCIES = gl/libgl.la
+-libQFrenderer_sw_la_LDFLAGS = @STATIC@
++libQFrenderer_sw_la_LDFLAGS = -version-info 1:0:0 -rpath $(libdir)
+ libQFrenderer_sw_la_LIBADD = sw/libsw.la
+ libQFrenderer_sw_la_SOURCES = $(common_sources)
+ libQFrenderer_sw_la_DEPENDENCIES = sw/libsw.la