aboutsummaryrefslogtreecommitdiff
path: root/games/ri-li
diff options
context:
space:
mode:
Diffstat (limited to 'games/ri-li')
-rw-r--r--games/ri-li/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/ri-li/Makefile b/games/ri-li/Makefile
index 154b16ef22e4..a807f510c827 100644
--- a/games/ri-li/Makefile
+++ b/games/ri-li/Makefile
@@ -19,9 +19,17 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl mixer
+MAKE_JOBS_SAFE= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` -I${LOCALBASE}/include"
+DESKTOP_ENTRIES="Ri-li" \
+ "Drive a toy wood train in many levels - snake-like arcade game" \
+ "${DATADIR}/Ri-li-icon-48x48.png" \
+ "Ri_li" \
+ "Game;ArcadeGame;" \
+ false
+
post-patch:
@${REINPLACE_CMD} -e 's|-lSDL |`${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/strcpy.*DefPath/ s|.*|strcpy(DefPath,"${DATADIR}/");|' ${WRKSRC}/src/main.cc