aboutsummaryrefslogtreecommitdiff
path: root/games/rtb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/rtb/Makefile')
-rw-r--r--games/rtb/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 03a2b485b0d5..e1e13d6f03e5 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -29,6 +29,12 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -37,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/RealTimeBattle.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>