aboutsummaryrefslogtreecommitdiff
path: root/games/scourge
diff options
context:
space:
mode:
Diffstat (limited to 'games/scourge')
-rw-r--r--games/scourge/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index b319634aa178..70f3e45a24a3 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -15,13 +15,12 @@ COMMENT= Rogue-like game
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${DATADIR}/config/scourge.cfg:${PORTSDIR}/games/scourge-data
-USE_AUTOTOOLS= autoconf:env automake:env
+USES= autoreconf gettext gmake
USE_GL= gl
USE_SDL= sdl image mixer net ttf
-USES= gmake
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_LIBS}
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-data-dir=${DATADIR}
@@ -35,9 +34,6 @@ DEBUG_CONFIGURE_ENABLE= debug
post-patch:
@${REINPLACE_CMD} -e 's|GLvoid|void|g' ${WRKSRC}/src/sdlhandler.cpp ${WRKSRC}/src/sdlhandler.h
-pre-configure:
- @cd ${WRKSRC} && ${AUTORECONF} -i
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/