aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/scummvm/Makefile')
-rw-r--r--games/scummvm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index 9956c99357e7..0c79e8e32fdf 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scummvm
-PORTVERSION= 2.1.0
+PORTVERSION= 2.1.1
CATEGORIES= games emulators
MASTER_SITES= http://www.scummvm.org/frs/scummvm/${PORTVERSION}/
@@ -21,7 +21,7 @@ LIB_DEPENDS= libfaad.so:audio/faad \
libmpeg2.so:multimedia/libmpeg2 \
libtheoradec.so:multimedia/libtheora
-USES= gmake gnome jpeg sdl tar:xz
+USES= gmake gnome iconv jpeg sdl tar:xz
HAS_CONFIGURE= yes
USE_SDL= sdl2
INSTALLS_ICONS= yes
@@ -39,6 +39,7 @@ LDFLAGS+= -lpthread
OPTIONS_DEFINE= DOCS FLAC FLUIDSYNTH MP3 MT32EMU PNG SNDIO VORBIS
OPTIONS_DEFAULT= MP3 MT32EMU PNG VORBIS
+OPTIONS_SUB= yes
MT32EMU_DESC= MT-32 emulator
@@ -46,7 +47,8 @@ VORBIS_LIB_DEPENDS= libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
VORBIS_CONFIGURE_ON= --with-ogg-prefix=${LOCALBASE} \
--with-vorbis-prefix=${LOCALBASE}
-VORBIS_CONFIGURE_OFF= --disable-vorbis
+VORBIS_CONFIGURE_OFF= --disable-vorbis \
+ --disable-ogg
MP3_LIB_DEPENDS= libmad.so:audio/libmad
MP3_CONFIGURE_ON= --with-mad-prefix=${LOCALBASE}