aboutsummaryrefslogtreecommitdiff
path: root/games/simsu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/simsu/Makefile')
-rw-r--r--games/simsu/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/games/simsu/Makefile b/games/simsu/Makefile
index 519a693d7674..fbab308acd3d 100644
--- a/games/simsu/Makefile
+++ b/games/simsu/Makefile
@@ -21,9 +21,20 @@ INSTALLS_ICONS= yes
PORTDOCS= CREDITS ChangeLog
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -i '' '/qm.files/,/qm.path/s/^/#/' \
+ ${WRKSRC}/${PORTNAME}.pro
+.endif
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/