aboutsummaryrefslogtreecommitdiff
path: root/games/starfighter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/starfighter/Makefile')
-rw-r--r--games/starfighter/Makefile43
1 files changed, 26 insertions, 17 deletions
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index d7c6ec32f09b..3cb7bb64dc8e 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -6,46 +6,55 @@ PORTVERSION= 1.2
PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/pr-${PORTNAME}/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Liberate the universe from the evil company WEAPCO
LICENSE= GPLv2
-USES= iconv
+USES= gmake iconv
USE_XORG= x11 xau xdmcp
USE_SDL= image mixer
WITH_ZLIB= yes
-USE_GMAKE= yes
MAKEFILE= makefile
INSTALLS_ICONS= yes
-DESKTOP_ENTRIES="Project Starfighter" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png \
+ %%DATADIR%%/${PORTNAME}.pak
+PLIST_DIRS= %%DATADIR%%
+
+PORTDOCS= index.html
+
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="Project Starfighter" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} \
- -e 's| -O2 -Wall|${CXXFLAGS}|' \
- -e 's|docs/\*|docs/index.html|' \
- -e 's|/usr|${LOCALBASE}|' \
- -e 's|$$(PREFIX)/games/|$$(PREFIX)/bin/|' \
- -e 's|/share/games/parallelrealities/|/share/starfighter/|' \
+ -e 's|mkdir -p $$(DESTDIR)$$(DOCDIR)|| ; \
+ s|cp -p $$(DOCS) $$(DESTDIR)$$(DOCDIR)|| ; \
+ s| -O2 -Wall|${CXXFLAGS}| ; \
+ s|docs/\*|docs/index.html| ; \
+ s|/usr|${LOCALBASE}| ; \
+ s|$$(PREFIX)/games/|$$(PREFIX)/bin/| ; \
+ s|/share/games/parallelrealities/|/share/starfighter/|' \
${WRKSRC}/makefile
-.if !${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -i '' -e '/$$(DESTDIR)$$(DOCDIR)/d' ${WRKSRC}/makefile
-.endif
-
post-install:
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>