aboutsummaryrefslogtreecommitdiff
path: root/games/starfighter
diff options
context:
space:
mode:
Diffstat (limited to 'games/starfighter')
-rw-r--r--games/starfighter/Makefile18
-rw-r--r--games/starfighter/distinfo6
-rw-r--r--games/starfighter/pkg-descr2
-rw-r--r--games/starfighter/pkg-plist23
4 files changed, 19 insertions, 30 deletions
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index cfa73a2b24e1..69e1fc535667 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= starfighter
-PORTVERSION= 1.7
+PORTVERSION= 2.0.0.2
+DISTVERSIONPREFIX= v
CATEGORIES= games
-MASTER_SITES= SAVANNAH/${PORTNAME}/${DISTVERSION} \
- SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
- ${PORTNAME}-icons${EXTRACT_SUFX}:icons
+MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
+DISTFILES= ${PORTNAME}-icons${EXTRACT_SUFX}:icons
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= alfix86@gmail.com
@@ -16,12 +15,13 @@ COMMENT= Liberate the universe from the evil company WEAPCO
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= dos2unix gmake gnome iconv pkgconfig sdl
-USE_SDL= image2 mixer2
+USES= autoreconf dos2unix gnome iconv pkgconfig sdl
+USE_SDL= image2 mixer2 ttf2
-GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= pr-starfighter
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}-src
+GNU_CONFIGURE= yes
DOS2UNIX_GLOB= *.txt
diff --git a/games/starfighter/distinfo b/games/starfighter/distinfo
index d45770dabb3e..43ef77c7e994 100644
--- a/games/starfighter/distinfo
+++ b/games/starfighter/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1561239089
-SHA256 (starfighter/starfighter-1.7-src.tar.gz) = 5b8c53ee680ad29558e244b59345fbc7c2100a542d2839dd74e22f84e5858698
-SIZE (starfighter/starfighter-1.7-src.tar.gz) = 46178626
+TIMESTAMP = 1565487894
SHA256 (starfighter/starfighter-icons.tar.gz) = 34a0b92f6b9d256aa1f201a72c00306212921de4921f2a37969cad73222ad6fc
SIZE (starfighter/starfighter-icons.tar.gz) = 38812
+SHA256 (starfighter/pr-starfighter-starfighter-v2.0.0.2_GH0.tar.gz) = 100562f2e12530ff4e360898ec5aace7f2c99806a9cba68d02466e82f8c1ae83
+SIZE (starfighter/pr-starfighter-starfighter-v2.0.0.2_GH0.tar.gz) = 50152978
diff --git a/games/starfighter/pkg-descr b/games/starfighter/pkg-descr
index e620999842a1..0a484c20daec 100644
--- a/games/starfighter/pkg-descr
+++ b/games/starfighter/pkg-descr
@@ -7,4 +7,4 @@ craft known as "Firefly" and begins his mission to fight his way to Sol,
freeing key systems along the way. The game opens with Chris attempting to
escape a Weapco patrol that has intercepted him.
-WWW: http://starfighter.nongnu.org/
+WWW: https://pr-starfighter.github.io/
diff --git a/games/starfighter/pkg-plist b/games/starfighter/pkg-plist
index ffce8fcd147d..a390a0eaf182 100644
--- a/games/starfighter/pkg-plist
+++ b/games/starfighter/pkg-plist
@@ -3,19 +3,6 @@ share/applications/starfighter.desktop
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/LICENSES
%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/docs/Makefile.am
-%%PORTDOCS%%%%DOCSDIR%%/docs/arrowNorthEast.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/dollar.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/heart.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/index.html
-%%PORTDOCS%%%%DOCSDIR%%/docs/plasmaAmmo.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/plasmaDamage.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/plasmaRate.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/rocket.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/rocketAmmo.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/sflogo.png
-%%PORTDOCS%%%%DOCSDIR%%/docs/superCharge.png
share/icons/hicolor/128x128/apps/starfighter.png
share/icons/hicolor/16x16/apps/starfighter.png
share/icons/hicolor/32x32/apps/starfighter.png
@@ -24,9 +11,9 @@ share/icons/hicolor/64x64/apps/starfighter.png
share/icons/hicolor/72x72/apps/starfighter.png
share/icons/hicolor/96x96/apps/starfighter.png
share/pixmaps/starfighter.png
-%%DATADIR%%/data/Makefile.am
+%%DATADIR%%/data/TakaoPGothic.ttf
%%DATADIR%%/data/credits.txt
-%%DATADIR%%/gfx/Makefile.am
+%%DATADIR%%/data/ipa_font_license.txt
%%DATADIR%%/gfx/aimFighter1.png
%%DATADIR%%/gfx/aimFighter2.png
%%DATADIR%%/gfx/alienDevice.png
@@ -216,7 +203,10 @@ share/pixmaps/starfighter.png
%%DATADIR%%/gfx/ursulaText.png
%%DATADIR%%/gfx/wingmate1.png
%%DATADIR%%/gfx/wingmate2.png
-%%DATADIR%%/music/Makefile.am
+%%DATADIR%%/locale/build.py
+%%DATADIR%%/locale/en.po
+%%DATADIR%%/locale/genpot.sh
+%%DATADIR%%/locale/pr-starfighter.pot
%%DATADIR%%/music/RE.ogg
%%DATADIR%%/music/death.ogg
%%DATADIR%%/music/frozen_jam.ogg
@@ -228,7 +218,6 @@ share/pixmaps/starfighter.png
%%DATADIR%%/music/space_dimensions.ogg
%%DATADIR%%/music/through_space.ogg
%%DATADIR%%/music/walking_among_androids.ogg
-%%DATADIR%%/sound/Makefile.am
%%DATADIR%%/sound/beamLaser.ogg
%%DATADIR%%/sound/cloak.ogg
%%DATADIR%%/sound/clock.ogg