aboutsummaryrefslogtreecommitdiff
path: root/games/stonesoup
diff options
context:
space:
mode:
Diffstat (limited to 'games/stonesoup')
-rw-r--r--games/stonesoup/Makefile14
-rw-r--r--games/stonesoup/distinfo4
-rw-r--r--games/stonesoup/files/patch-Makefile25
-rw-r--r--games/stonesoup/files/patch-dat__des__builder__shops.des14
-rw-r--r--games/stonesoup/files/patch-dat__des__variable__grated_community.des32
-rw-r--r--games/stonesoup/files/patch-files.cc24
-rw-r--r--games/stonesoup/files/patch-ng-setup.cc14
-rw-r--r--games/stonesoup/files/patch-rltiles__tool__tile.cc6
-rw-r--r--games/stonesoup/files/patch-startup.cc13
-rw-r--r--games/stonesoup/pkg-plist154
10 files changed, 137 insertions, 163 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 4ad9182f22db..3674f3c10795 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= stonesoup
-PORTVERSION= 0.13.1
-PORTREVISION= 1
+PORTVERSION= 0.14.1
CATEGORIES= games
MASTER_SITES= SF/crawl-ref/Stone%20Soup/${PORTVERSION}
DISTNAME= stone_soup-${PORTVERSION}-nodeps
@@ -15,8 +14,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKDIR}/stone_soup-${PORTVERSION}/licence.txt
USE_SQLITE= yes
-USE_XZ= yes
-USES= bison gmake perl5 pkgconfig
+USES= bison compiler gmake perl5 pkgconfig tar:xz
USE_LUA= 5.1
USE_PERL5= build
@@ -61,7 +59,7 @@ PKGNAMESUFFIX= -sdl
BUILD_DEPENDS+= fc-list:${PORTSDIR}/x11-fonts/fontconfig \
${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
USE_SDL= sdl image
.else
@@ -80,7 +78,7 @@ MAKE_ARGS+= NO_LUA_BINDINGS=yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1000100
+.if ${COMPILER_TYPE} == clang
CFLAGS+= -std=c++0x
.endif
@@ -98,10 +96,10 @@ pre-install:
${XARGS} ${RM}
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.FreeBSD ${STAGEDIR}${DOCSDIR}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${STAGEDIR}${DATADIR}/settings/init.txt ${STAGEDIR}${EXAMPLESDIR}/sample.crawlrc
.include <bsd.port.post.mk>
diff --git a/games/stonesoup/distinfo b/games/stonesoup/distinfo
index 4df09263b39e..510c9b9c297b 100644
--- a/games/stonesoup/distinfo
+++ b/games/stonesoup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stone_soup-0.13.1-nodeps.tar.xz) = 9e32ca7e48bc3e12ce6bc8d963b01a0bce3f5826c6ca1d60947867f5602921e8
-SIZE (stone_soup-0.13.1-nodeps.tar.xz) = 9456356
+SHA256 (stone_soup-0.14.1-nodeps.tar.xz) = 91726d0224b93ba26b5d4bd3762bc5aabe1f02974ea6c937be89dc6c6ab7a4dd
+SIZE (stone_soup-0.14.1-nodeps.tar.xz) = 8903416
diff --git a/games/stonesoup/files/patch-Makefile b/games/stonesoup/files/patch-Makefile
index bf6eda80eaf0..5d3c45f1a06e 100644
--- a/games/stonesoup/files/patch-Makefile
+++ b/games/stonesoup/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 2013-09-30 20:32:00.000000000 +0200
-+++ ./Makefile 2013-10-11 22:07:08.167887693 +0200
+--- ./Makefile.orig 2014-04-28 16:57:38.000000000 +0200
++++ ./Makefile 2014-05-06 21:21:37.798136726 +0200
@@ -69,7 +69,7 @@
# ask for a package with convenience libraries instead -- we'll try to provide
# them somewhere in the near future.
@@ -62,9 +62,18 @@
- LUA_PACKAGE = lua5.1
+ LUA_PACKAGE = lua-5.1
endif
- INCLUDES_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-I)
+ INCLUDES_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-I | sed -e 's/-I/-isystem /')
CFLAGS_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-other)
-@@ -754,7 +752,7 @@
+@@ -611,7 +609,7 @@
+
+ ifndef BUILD_SQLITE
+ ifeq ($(shell grep -q sqlite3_prepare $(SQLITE_INCLUDE_DIR)/sqlite3.h 2>/dev/null && echo yes),yes)
+- # INCLUDES_L += -isystem $(SQLITE_INCLUDE_DIR)
++ INCLUDES_L += -isystem $(SQLITE_INCLUDE_DIR)
+ LIBS += $(SQLITE_LIB)
+ ifneq ($(shell grep -q sqlite3_prepare_v2 $(SQLITE_INCLUDE_DIR)/sqlite3.h 2>/dev/null && echo yes),yes)
+ DEFINES_L += -DANCIENT_SQLITE
+@@ -756,7 +754,7 @@
DEFINES += -DWIZARD
endif
ifdef NO_OPTIMIZE
@@ -73,7 +82,7 @@
endif
ifdef PCH
-@@ -878,7 +876,7 @@
+@@ -880,7 +878,7 @@
INSTALL_FONTS += $(PROPORTIONAL_FONT)
endif
else
@@ -82,7 +91,7 @@
ifeq (,$(SYS_PROPORTIONAL_FONT))
SYS_PROPORTIONAL_FONT = $(shell dir=/usr/local/share/fonts ; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
endif
-@@ -901,7 +899,7 @@
+@@ -903,7 +901,7 @@
INSTALL_FONTS += $(MONOSPACED_FONT)
endif
else
@@ -91,9 +100,9 @@
ifeq (,$(SYS_MONOSPACED_FONT))
SYS_MONOSPACED_FONT = $(shell dir=/usr/local/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
endif
-@@ -1091,7 +1089,7 @@
- cmd-name.h
+@@ -1099,7 +1097,7 @@
+ LANGUAGES = $(filter-out en, $(notdir $(wildcard dat/descript/??)))
SRC_PKG_BASE := stone_soup
-SRC_VERSION := $(shell git describe --tags $(MERGE_BASE) 2>/dev/null || cat util/release_ver)
+SRC_VERSION := $(shell cat util/release_ver)
diff --git a/games/stonesoup/files/patch-dat__des__builder__shops.des b/games/stonesoup/files/patch-dat__des__builder__shops.des
index 8cb3356ef531..e9a8e03166c5 100644
--- a/games/stonesoup/files/patch-dat__des__builder__shops.des
+++ b/games/stonesoup/files/patch-dat__des__builder__shops.des
@@ -1,6 +1,6 @@
---- ./dat/des/builder/shops.des.orig 2013-09-30 20:32:00.000000000 +0200
-+++ ./dat/des/builder/shops.des 2013-10-11 22:07:08.169887952 +0200
-@@ -228,15 +228,7 @@
+--- ./dat/des/builder/shops.des.orig 2014-04-24 22:39:22.000000000 +0200
++++ ./dat/des/builder/shops.des 2014-05-06 21:23:13.323133248 +0200
+@@ -390,15 +390,7 @@
: local shopname = util.random_from({"type:Blasphemy suffix:Boutique",
: "type:Evil suffix:Emporium", "type:Profane suffix:Products",
: "type:Sacrilege suffix:Store", "type:Wicked suffix:Wares"})
@@ -8,12 +8,12 @@
-: potion of blood | any weapon ego:draining w:15 | any weapon ego:pain w:5 | \
-: any weapon ego:vampiricism w:5 | demon blade w:5 | \
-: demon whip w:5 | demon trident w:5 | wand of draining | scroll of torment | \
--: staff of death | rod of demonology w:5 | \
--: bottled efreet w:5 | lantern of shadows w:5 | book of necromancy | book of death | \
+-: staff of death | \
+-: lantern of shadows w:5 | book of necromancy | book of death | \
-: book of unlife | randbook disc:necromancy w:5 | necronomicon w:1 | \
-: grand grimoire w:1 | scythe unrand:scythe_of_curses w:1 | \
--: long sword unrand:sword_of_zonguldrok w:1 | mace unrand:sceptre_of_torment w:1")
-+: kfeat("s = general shop " .. shopname .. " ; potion of blood | any weapon ego:draining w:15 | any weapon ego:pain w:5 | any weapon ego:vampiricism w:5 | demon blade w:5 | demon whip w:5 | demon trident w:5 | wand of draining | scroll of torment | staff of death | rod of demonology w:5 | bottled efreet w:5 | lantern of shadows w:5 | book of necromancy | book of death | book of unlife | randbook disc:necromancy w:5 | necronomicon w:1 | grand grimoire w:1 | scythe unrand:scythe_of_curses w:1 | long sword unrand:sword_of_zonguldrok w:1 | mace unrand:sceptre_of_torment w:1")
+-: bastard sword unrand:sword_of_zonguldrok w:1 | mace unrand:sceptre_of_torment w:1")
++: kfeat("s = general shop " .. shopname .. " ; potion of blood | any weapon ego:draining w:15 | any weapon ego:pain w:5 | any weapon ego:vampiricism w:5 | demon blade w:5 | demon whip w:5 | demon trident w:5 | wand of draining | scroll of torment | staff of death | lantern of shadows w:5 | book of necromancy | book of death | book of unlife | randbook disc:necromancy w:5 | necronomicon w:1 | grand grimoire w:1 | scythe unrand:scythe_of_curses w:1 | bastard sword unrand:sword_of_zonguldrok w:1 | mace unrand:sceptre_of_torment w:1")
KFEAT: a = altar_kikubaaqudgha / altar_yredelemnul / altar_makhleb / \
altar_beogh w:1 / altar_lugonu w:1
MAP
diff --git a/games/stonesoup/files/patch-dat__des__variable__grated_community.des b/games/stonesoup/files/patch-dat__des__variable__grated_community.des
index 5a6eeaedc6a9..ce41cd1213f5 100644
--- a/games/stonesoup/files/patch-dat__des__variable__grated_community.des
+++ b/games/stonesoup/files/patch-dat__des__variable__grated_community.des
@@ -1,27 +1,27 @@
---- ./dat/des/variable/grated_community.des.orig 2013-10-11 22:08:21.868888937 +0200
-+++ ./dat/des/variable/grated_community.des 2013-10-11 22:12:02.503889567 +0200
+--- ./dat/des/variable/grated_community.des.orig 2014-04-09 17:36:32.000000000 +0200
++++ ./dat/des/variable/grated_community.des 2014-05-06 21:21:37.804135690 +0200
@@ -67,11 +67,7 @@
- q:5 sausage
KFEAT: C = distillery shop type:Miraculous suffix:Elixirs count:10 \
greed:50 ; potion of confusion
--: kfeat("D = armour shop name:The_Legendary_" .. crawl.make_name() .. " \
+ : local smithy = string.gsub(crawl.make_name(), " ", "_")
+-: kfeat("D = armour shop name:The_Legendary_" .. smithy .. " \
-: type:Legendary suffix:Smithy count:10 greed:40 ;\
-: damaged plate armour ego:none | damaged chain mail ego:none |\
-: damaged long sword ego:none | damaged shield ego:none |\
-: damaged large shield ego:none | damaged battleaxe ego:none")
-+: kfeat("D = armour shop name:The_Legendary_" .. crawl.make_name() .. " type:Legendary suffix:Smithy count:10 greed:40 ; damaged plate armour ego:none | damaged chain mail ego:none | damaged long sword ego:none | damaged shield ego:none | damaged large shield ego:none | damaged battleaxe ego:none")
++: kfeat("D = armour shop name:The_Legendary_" .. smithy .. " type:Legendary suffix:Smithy count:10 greed:40 ; damaged plate armour ego:none | damaged chain mail ego:none | damaged long sword ego:none | damaged shield ego:none | damaged large shield ego:none | damaged battleaxe ego:none")
SHUFFLE: QRSTUVX
SUBVAULT: Q : grated_community_mu_home1
SUBVAULT: R : grated_community_mu_home2
-@@ -166,16 +162,11 @@
- KITEM: % = animal skin / nothing
- MARKER: + = lua:restrict_door()
+@@ -168,16 +164,11 @@
KFEAT: ~ = closed_door
--: dgn.delayed_decay(_G, '*', 'human skeleton / yak skeleton / elf skeleton /\
--: gnome skeleton / elephant skeleton /\
--: sheep skeleton / manticore skeleton /\
--: w:2 nothing, animal skin')
-+: dgn.delayed_decay(_G, '*', 'human skeleton / yak skeleton / elf skeleton / gnome skeleton / elephant skeleton / sheep skeleton / manticore skeleton / w:2 nothing, animal skin')
+ SUBST: * = *:35 -:1
+ KITEM: - = animal skin
+-: dgn.delayed_decay_extra(_G, '*', 'human skeleton / yak skeleton /\
+-: elf skeleton / kobold skeleton /\
+-: elephant skeleton / sheep skeleton /\
+-: manticore skeleton', 'animal skin')
++: dgn.delayed_decay_extra(_G, '*', 'human skeleton / yak skeleton / elf skeleton / kobold skeleton / elephant skeleton / sheep skeleton / manticore skeleton', 'animal skin')
KFEAT: 8 = granite_statue / orcish_idol / w:5 altar_trog /\
w:5 altar_beogh / w:1 altar_makhleb / w:4 floor
KITEM: $ = q:5 meat ration, giant spiked club, q:2 sausage
@@ -32,7 +32,7 @@
: local frosty = crawl.random2(6)
: if frosty == 5 then
SUBST: 1 = 2
-@@ -218,10 +209,8 @@
+@@ -220,10 +211,8 @@
KFEAT: * = altar_kikubaaqudgha / w:4 altar_sif_muna / w:1 altar_yredelemnul
KITEM: " = gold, any wand / w:15 nothing, any scroll / nothing
KFEAT: 8 = granite_statue / w:2 fountain_blood / w:1 floor
@@ -45,7 +45,7 @@
KITEM: & = book of necromancy / book of death / book of unlife / w:12 nothing
KMONS: P = col:darkgrey plant name:withered name_adjective \
tile:mons_withered_plant / col:lightgrey plant name:withered \
-@@ -233,8 +222,7 @@
+@@ -235,8 +224,7 @@
nothing
KFEAT: 8 = granite_statue / fountain_sparkling / fountain_blue / w:1 floor
KITEM: ? = scroll of recharging / nothing, any scroll / nothing
@@ -55,7 +55,7 @@
KITEM: & = book of wizardry / book of power / book of party tricks /\
book of alchemy / w:12 nothing
KMONS: P = plant
-@@ -246,8 +234,7 @@
+@@ -248,8 +236,7 @@
potion of brilliance / nothing
KFEAT: 8 = granite_statue / w:1 floor
KITEM: ? = scroll of immolation / nothing, any scroll / nothing
diff --git a/games/stonesoup/files/patch-files.cc b/games/stonesoup/files/patch-files.cc
deleted file mode 100644
index cfc5c9666dfe..000000000000
--- a/games/stonesoup/files/patch-files.cc
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./files.cc.orig 2013-09-30 20:32:00.000000000 +0200
-+++ ./files.cc 2013-10-11 22:07:08.172887580 +0200
-@@ -626,8 +626,10 @@
- {
- vector<player_save_info> chars;
-
-+#ifdef WIZARD
- if (Options.no_save)
- return chars;
-+#endif
-
- #ifndef DISABLE_SAVEGAME_LISTS
- string searchpath = _get_savefile_directory();
-@@ -1792,8 +1794,10 @@
- // returns false if a new game should start instead
- static bool _restore_game(const string& filename)
- {
-+#ifdef WIZARD
- if (Options.no_save)
- return false;
-+#endif
-
- you.save = new package((_get_savefile_directory() + filename).c_str(), true);
-
diff --git a/games/stonesoup/files/patch-ng-setup.cc b/games/stonesoup/files/patch-ng-setup.cc
deleted file mode 100644
index 1b10706fd1be..000000000000
--- a/games/stonesoup/files/patch-ng-setup.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./ng-setup.cc.orig 2013-09-30 20:32:18.000000000 +0200
-+++ ./ng-setup.cc 2013-10-11 22:07:08.174888114 +0200
-@@ -1430,9 +1430,11 @@
- init_companions();
-
- // Create the save file.
-+#ifdef WIZARD
- if (Options.no_save)
- you.save = new package();
- else
-+#endif
- you.save = new package(get_savedir_filename(you.your_name).c_str(),
- true, true);
- }
diff --git a/games/stonesoup/files/patch-rltiles__tool__tile.cc b/games/stonesoup/files/patch-rltiles__tool__tile.cc
index a4387a5af43f..ecb6243d7498 100644
--- a/games/stonesoup/files/patch-rltiles__tool__tile.cc
+++ b/games/stonesoup/files/patch-rltiles__tool__tile.cc
@@ -1,6 +1,6 @@
---- ./rltiles/tool/tile.cc.orig 2013-09-30 20:32:00.000000000 +0200
-+++ ./rltiles/tool/tile.cc 2013-10-11 22:07:08.178890955 +0200
-@@ -125,10 +125,10 @@
+--- ./rltiles/tool/tile.cc.orig 2014-04-09 17:36:33.000000000 +0200
++++ ./rltiles/tool/tile.cc 2014-05-06 21:21:37.808135615 +0200
+@@ -123,10 +123,10 @@
if (flags[x + y * m_width])
continue;
diff --git a/games/stonesoup/files/patch-startup.cc b/games/stonesoup/files/patch-startup.cc
deleted file mode 100644
index df79fd06b67b..000000000000
--- a/games/stonesoup/files/patch-startup.cc
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./startup.cc.orig 2013-09-30 20:32:00.000000000 +0200
-+++ ./startup.cc 2013-10-11 22:07:08.183889437 +0200
-@@ -240,8 +240,10 @@
- you.wizard = true;
- #endif
- // Save-less games are pointless except for tests.
-+#ifdef WIZARD
- if (Options.no_save)
- you.wizard = true;
-+#endif
-
- init_properties();
- burden_change();
diff --git a/games/stonesoup/pkg-plist b/games/stonesoup/pkg-plist
index 4b2b89e2811e..f75ba7800214 100644
--- a/games/stonesoup/pkg-plist
+++ b/games/stonesoup/pkg-plist
@@ -2,6 +2,7 @@ bin/stonesoup
%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.crawlrc
%%DATADIR%%/dat/clua/autofight.lua
+%%DATADIR%%/dat/clua/automagic.lua
%%DATADIR%%/dat/clua/gearset.lua
%%DATADIR%%/dat/clua/kills.lua
%%DATADIR%%/dat/clua/runrest.lua
@@ -48,13 +49,19 @@ bin/stonesoup
%%DATADIR%%/dat/des/altar/vehumet_trees.des
%%DATADIR%%/dat/des/altar/xom_monty_hall.des
%%DATADIR%%/dat/des/altar/yredelemnul_ordeal.des
+%%DATADIR%%/dat/des/arrival/arrival_guide.txt
+%%DATADIR%%/dat/des/arrival/large.des
+%%DATADIR%%/dat/des/arrival/simple.des
+%%DATADIR%%/dat/des/arrival/small.des
+%%DATADIR%%/dat/des/arrival/twisted.des
%%DATADIR%%/dat/des/branches/abyss.des
%%DATADIR%%/dat/des/branches/blade.des
%%DATADIR%%/dat/des/branches/coc.des
%%DATADIR%%/dat/des/branches/crypt.des
+%%DATADIR%%/dat/des/branches/depths.des
+%%DATADIR%%/dat/des/branches/depths_encompass.des
%%DATADIR%%/dat/des/branches/dis.des
%%DATADIR%%/dat/des/branches/elf.des
-%%DATADIR%%/dat/des/branches/forest.des
%%DATADIR%%/dat/des/branches/geh.des
%%DATADIR%%/dat/des/branches/hell.des
%%DATADIR%%/dat/des/branches/lair.des
@@ -90,11 +97,6 @@ bin/stonesoup
%%DATADIR%%/dat/des/builder/rooms.des
%%DATADIR%%/dat/des/builder/shops.des
%%DATADIR%%/dat/des/builder/uniques.des
-%%DATADIR%%/dat/des/entry/entry_guide.txt
-%%DATADIR%%/dat/des/entry/large.des
-%%DATADIR%%/dat/des/entry/simple.des
-%%DATADIR%%/dat/des/entry/small.des
-%%DATADIR%%/dat/des/entry/twisted.des
%%DATADIR%%/dat/des/guide.txt
%%DATADIR%%/dat/des/portals/bailey.des
%%DATADIR%%/dat/des/portals/bazaar.des
@@ -116,10 +118,10 @@ bin/stonesoup
%%DATADIR%%/dat/des/serial/gnoll_camp.des
%%DATADIR%%/dat/des/serial/ice.des
%%DATADIR%%/dat/des/serial/magic_research.des
+%%DATADIR%%/dat/des/serial/park.des
%%DATADIR%%/dat/des/serial/ponds.des
%%DATADIR%%/dat/des/serial/serial_guide.txt
%%DATADIR%%/dat/des/serial/sigils.des
-%%DATADIR%%/dat/des/serial/teleporters.des
%%DATADIR%%/dat/des/serial/undead.des
%%DATADIR%%/dat/des/serial/window.des
%%DATADIR%%/dat/des/sprint/arena_sprint.des
@@ -132,23 +134,24 @@ bin/stonesoup
%%DATADIR%%/dat/des/sprint/sprint_mu.des
%%DATADIR%%/dat/des/sprint/zigsprint.des
%%DATADIR%%/dat/des/test.des
+%%DATADIR%%/dat/des/test/suite-los.des
+%%DATADIR%%/dat/des/test/suite.des
%%DATADIR%%/dat/des/traps/beogh_trap.des
%%DATADIR%%/dat/des/traps/boulders.des
%%DATADIR%%/dat/des/traps/grate.des
%%DATADIR%%/dat/des/traps/rats_trap.des
%%DATADIR%%/dat/des/traps/spider_basket.des
-%%DATADIR%%/dat/des/traps/xom_trap.des
-%%DATADIR%%/dat/des/tutorial/lesson1.des
+%%DATADIR%%/dat/des/tutorial/lesson%%LUA_VER_SH%%.des
%%DATADIR%%/dat/des/tutorial/lesson2.des
%%DATADIR%%/dat/des/tutorial/lesson3.des
%%DATADIR%%/dat/des/tutorial/lesson4.des
%%DATADIR%%/dat/des/tutorial/lesson5.des
%%DATADIR%%/dat/des/variable/ambush.des
%%DATADIR%%/dat/des/variable/ancient_champions.des
+%%DATADIR%%/dat/des/variable/arcadia.des
%%DATADIR%%/dat/des/variable/cathedral_bats.des
%%DATADIR%%/dat/des/variable/compat.des
-%%DATADIR%%/dat/des/variable/dk_crumbling.des
-%%DATADIR%%/dat/des/variable/encompass.des
+%%DATADIR%%/dat/des/variable/d_encompass.des
%%DATADIR%%/dat/des/variable/float.des
%%DATADIR%%/dat/des/variable/geyser.des
%%DATADIR%%/dat/des/variable/grated_community.des
@@ -158,7 +161,6 @@ bin/stonesoup
%%DATADIR%%/dat/des/variable/mini.des
%%DATADIR%%/dat/des/variable/mini_features.des
%%DATADIR%%/dat/des/variable/mini_monsters.des
-%%DATADIR%%/dat/des/variable/tomb_raider.des
%%DATADIR%%/dat/des/zotdef/zotdef.des
%%DATADIR%%/dat/descript/ability.txt
%%DATADIR%%/dat/descript/backgrounds.txt
@@ -267,7 +269,6 @@ bin/stonesoup
%%DATADIR%%/dat/descript/hints.txt
%%DATADIR%%/dat/descript/hu/backgrounds.txt
%%DATADIR%%/dat/descript/hu/species.txt
-%%DATADIR%%/dat/descript/it/ability.txt
%%DATADIR%%/dat/descript/it/backgrounds.txt
%%DATADIR%%/dat/descript/it/branches.txt
%%DATADIR%%/dat/descript/it/cards.txt
@@ -280,7 +281,6 @@ bin/stonesoup
%%DATADIR%%/dat/descript/it/quotes.txt
%%DATADIR%%/dat/descript/it/skills.txt
%%DATADIR%%/dat/descript/it/species.txt
-%%DATADIR%%/dat/descript/it/spells.txt
%%DATADIR%%/dat/descript/it/tutorial.txt
%%DATADIR%%/dat/descript/it/unident.txt
%%DATADIR%%/dat/descript/it/unrand.txt
@@ -288,8 +288,10 @@ bin/stonesoup
%%DATADIR%%/dat/descript/ja/ability.txt
%%DATADIR%%/dat/descript/ja/backgrounds.txt
%%DATADIR%%/dat/descript/ja/branches.txt
+%%DATADIR%%/dat/descript/ja/cards.txt
%%DATADIR%%/dat/descript/ja/commands.txt
%%DATADIR%%/dat/descript/ja/gods.txt
+%%DATADIR%%/dat/descript/ja/hints.txt
%%DATADIR%%/dat/descript/ja/items.txt
%%DATADIR%%/dat/descript/ja/monsters.txt
%%DATADIR%%/dat/descript/ja/skills.txt
@@ -324,6 +326,7 @@ bin/stonesoup
%%DATADIR%%/dat/descript/lt/unident.txt
%%DATADIR%%/dat/descript/lv/ability.txt
%%DATADIR%%/dat/descript/lv/backgrounds.txt
+%%DATADIR%%/dat/descript/lv/branches.txt
%%DATADIR%%/dat/descript/lv/cards.txt
%%DATADIR%%/dat/descript/lv/commands.txt
%%DATADIR%%/dat/descript/lv/features.txt
@@ -332,8 +335,10 @@ bin/stonesoup
%%DATADIR%%/dat/descript/lv/items.txt
%%DATADIR%%/dat/descript/lv/monsters.txt
%%DATADIR%%/dat/descript/lv/skills.txt
+%%DATADIR%%/dat/descript/lv/species.txt
%%DATADIR%%/dat/descript/lv/spells.txt
%%DATADIR%%/dat/descript/lv/tutorial.txt
+%%DATADIR%%/dat/descript/lv/unident.txt
%%DATADIR%%/dat/descript/lv/unrand.txt
%%DATADIR%%/dat/descript/monsters.txt
%%DATADIR%%/dat/descript/nl/ability.txt
@@ -342,8 +347,12 @@ bin/stonesoup
%%DATADIR%%/dat/descript/pl/ability.txt
%%DATADIR%%/dat/descript/pl/backgrounds.txt
%%DATADIR%%/dat/descript/pl/cards.txt
+%%DATADIR%%/dat/descript/pl/commands.txt
+%%DATADIR%%/dat/descript/pl/features.txt
%%DATADIR%%/dat/descript/pl/gods.txt
+%%DATADIR%%/dat/descript/pl/hints.txt
%%DATADIR%%/dat/descript/pl/items.txt
+%%DATADIR%%/dat/descript/pl/monsters.txt
%%DATADIR%%/dat/descript/pl/quotes.txt
%%DATADIR%%/dat/descript/pl/skills.txt
%%DATADIR%%/dat/descript/pl/species.txt
@@ -382,6 +391,8 @@ bin/stonesoup
%%DATADIR%%/dat/descript/tr/commands.txt
%%DATADIR%%/dat/descript/tr/gods.txt
%%DATADIR%%/dat/descript/tr/items.txt
+%%DATADIR%%/dat/descript/tr/quotes.txt
+%%DATADIR%%/dat/descript/tr/species.txt
%%DATADIR%%/dat/descript/tr/tutorial.txt
%%DATADIR%%/dat/descript/tr/unident.txt
%%DATADIR%%/dat/descript/tr/unrand.txt
@@ -398,6 +409,7 @@ bin/stonesoup
%%DATADIR%%/dat/descript/zh/hints.txt
%%DATADIR%%/dat/descript/zh/items.txt
%%DATADIR%%/dat/descript/zh/monsters.txt
+%%DATADIR%%/dat/descript/zh/quotes.txt
%%DATADIR%%/dat/descript/zh/skills.txt
%%DATADIR%%/dat/descript/zh/species.txt
%%DATADIR%%/dat/descript/zh/spells.txt
@@ -431,7 +443,7 @@ bin/stonesoup
%%DATADIR%%/dat/dlua/layout/theme.lua
%%DATADIR%%/dat/dlua/layout/vector.lua
%%DATADIR%%/dat/dlua/layout/zonify.lua
-%%DATADIR%%/dat/dlua/lm_1way.lua
+%%DATADIR%%/dat/dlua/lm_%%LUA_VER_SH%%way.lua
%%DATADIR%%/dat/dlua/lm_door.lua
%%DATADIR%%/dat/dlua/lm_fog.lua
%%DATADIR%%/dat/dlua/lm_items.lua
@@ -464,6 +476,7 @@ bin/stonesoup
%%DATADIR%%/dat/dlua/v_paint.lua
%%DATADIR%%/dat/dlua/v_rooms.lua
%%DATADIR%%/dat/dlua/v_shapes.lua
+%%DATADIR%%/dat/dlua/vault.lua
%%DATADIR%%/dat/dlua/ziggurat.lua
%%SDL%%%%DATADIR%%/dat/tiles/feat.png
%%SDL%%%%DATADIR%%/dat/tiles/floor.png
@@ -473,8 +486,10 @@ bin/stonesoup
%%SDL%%%%DATADIR%%/dat/tiles/main.png
%%SDL%%%%DATADIR%%/dat/tiles/player.png
%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-32x32.png
-%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-512x512.png
+%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-%%LUA_VER_STR%%2x%%LUA_VER_STR%%2.png
%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-win32.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_baconkid_gastronok.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_baconkid_mnoleg.png
%%SDL%%%%DATADIR%%/dat/tiles/title_denzi_dragon.png
%%SDL%%%%DATADIR%%/dat/tiles/title_denzi_evil_mage.png
%%SDL%%%%DATADIR%%/dat/tiles/title_denzi_invasion.png
@@ -485,6 +500,7 @@ bin/stonesoup
%%SDL%%%%DATADIR%%/dat/tiles/title_omndra_zot_demon.png
%%SDL%%%%DATADIR%%/dat/tiles/title_pooryurik_knight.png
%%SDL%%%%DATADIR%%/dat/tiles/title_psiweapon_kiku.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_psiweapon_roxanne.png
%%SDL%%%%DATADIR%%/dat/tiles/title_shadyamish_octm.png
%%SDL%%%%DATADIR%%/dat/tiles/title_white_noise_entering_the_dungeon.png
%%SDL%%%%DATADIR%%/dat/tiles/title_white_noise_grabbing_the_orb.png
@@ -513,7 +529,6 @@ bin/stonesoup
%%DATADIR%%/docs/develop/tiles_creation.txt
%%DATADIR%%/docs/develop/translation.txt
%%DATADIR%%/docs/fight_simulator.txt
-%%DATADIR%%/docs/key_changes.txt
%%DATADIR%%/docs/keybind.txt
%%DATADIR%%/docs/license/cc0.txt
%%DATADIR%%/docs/license/lgpl.txt
@@ -526,64 +541,67 @@ bin/stonesoup
%%DATADIR%%/docs/quickstart.txt
%%DATADIR%%/docs/ssh_guide.txt
%%DATADIR%%/docs/tiles_help.txt
-%%DATADIR%%/settings/0.12_monster_glyphs.txt
+%%DATADIR%%/settings/0.%%LUA_VER_SH%%2_monster_glyphs.txt
+%%DATADIR%%/settings/0.%%LUA_VER_SH%%3_monster_glyphs.txt
%%DATADIR%%/settings/0.9_monster_glyphs.txt
%%DATADIR%%/settings/034_command_keys.txt
%%DATADIR%%/settings/034_monster_glyphs.txt
%%DATADIR%%/settings/052_monster_glyphs.txt
%%DATADIR%%/settings/060_monster_glyphs.txt
-%%DATADIR%%/settings/071_monster_glyphs.txt
+%%DATADIR%%/settings/07%%LUA_VER_SH%%_monster_glyphs.txt
%%DATADIR%%/settings/080_monster_glyphs.txt
%%DATADIR%%/settings/advanced_optioneering.txt
+%%DATADIR%%/settings/colemak_command_keys.txt
%%DATADIR%%/settings/dvorak_command_keys.txt
%%DATADIR%%/settings/init.txt
%%DATADIR%%/settings/no_vi_command_keys.txt
-@dirrmtry %%DATADIR%%/settings
-@dirrmtry %%DATADIR%%/docs/license
-@dirrmtry %%DATADIR%%/docs/develop/levels
-@dirrmtry %%DATADIR%%/docs/develop
-@dirrmtry %%DATADIR%%/docs
-%%SDL%%@dirrmtry %%DATADIR%%/dat/tiles
-@dirrmtry %%DATADIR%%/dat/dlua/layout
-@dirrmtry %%DATADIR%%/dat/dlua
-@dirrmtry %%DATADIR%%/dat/descript/zh
-@dirrmtry %%DATADIR%%/dat/descript/tr
-@dirrmtry %%DATADIR%%/dat/descript/ru
-@dirrmtry %%DATADIR%%/dat/descript/pt
-@dirrmtry %%DATADIR%%/dat/descript/pl
-@dirrmtry %%DATADIR%%/dat/descript/nl
-@dirrmtry %%DATADIR%%/dat/descript/lv
-@dirrmtry %%DATADIR%%/dat/descript/lt
-@dirrmtry %%DATADIR%%/dat/descript/ko
-@dirrmtry %%DATADIR%%/dat/descript/ja
-@dirrmtry %%DATADIR%%/dat/descript/it
-@dirrmtry %%DATADIR%%/dat/descript/hu
-@dirrmtry %%DATADIR%%/dat/descript/fr
-@dirrmtry %%DATADIR%%/dat/descript/fi
-@dirrmtry %%DATADIR%%/dat/descript/es
-@dirrmtry %%DATADIR%%/dat/descript/el
-@dirrmtry %%DATADIR%%/dat/descript/de
-@dirrmtry %%DATADIR%%/dat/descript/da
-@dirrmtry %%DATADIR%%/dat/descript/cs
-@dirrmtry %%DATADIR%%/dat/descript
-@dirrmtry %%DATADIR%%/dat/des/zotdef
-@dirrmtry %%DATADIR%%/dat/des/variable
-@dirrmtry %%DATADIR%%/dat/des/tutorial
-@dirrmtry %%DATADIR%%/dat/des/traps
-@dirrmtry %%DATADIR%%/dat/des/sprint
-@dirrmtry %%DATADIR%%/dat/des/serial
-@dirrmtry %%DATADIR%%/dat/des/portals
-@dirrmtry %%DATADIR%%/dat/des/entry
-@dirrmtry %%DATADIR%%/dat/des/builder
-@dirrmtry %%DATADIR%%/dat/des/branches
-@dirrmtry %%DATADIR%%/dat/des/altar
-@dirrmtry %%DATADIR%%/dat/des
-@dirrmtry %%DATADIR%%/dat/defaults
-@dirrmtry %%DATADIR%%/dat/database/pl
-@dirrmtry %%DATADIR%%/dat/database/el
-@dirrmtry %%DATADIR%%/dat/database
-@dirrmtry %%DATADIR%%/dat/clua
-@dirrmtry %%DATADIR%%/dat
-@dirrmtry %%DATADIR%%
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%/dat/clua
+@dirrm %%DATADIR%%/dat/database/el
+@dirrm %%DATADIR%%/dat/database/pl
+@dirrm %%DATADIR%%/dat/database
+@dirrm %%DATADIR%%/dat/defaults
+@dirrm %%DATADIR%%/dat/des/altar
+@dirrm %%DATADIR%%/dat/des/arrival
+@dirrm %%DATADIR%%/dat/des/branches
+@dirrm %%DATADIR%%/dat/des/builder
+@dirrm %%DATADIR%%/dat/des/portals
+@dirrm %%DATADIR%%/dat/des/serial
+@dirrm %%DATADIR%%/dat/des/sprint
+@dirrm %%DATADIR%%/dat/des/test
+@dirrm %%DATADIR%%/dat/des/traps
+@dirrm %%DATADIR%%/dat/des/tutorial
+@dirrm %%DATADIR%%/dat/des/variable
+@dirrm %%DATADIR%%/dat/des/zotdef
+@dirrm %%DATADIR%%/dat/des
+@dirrm %%DATADIR%%/dat/descript/cs
+@dirrm %%DATADIR%%/dat/descript/da
+@dirrm %%DATADIR%%/dat/descript/de
+@dirrm %%DATADIR%%/dat/descript/el
+@dirrm %%DATADIR%%/dat/descript/es
+@dirrm %%DATADIR%%/dat/descript/fi
+@dirrm %%DATADIR%%/dat/descript/fr
+@dirrm %%DATADIR%%/dat/descript/hu
+@dirrm %%DATADIR%%/dat/descript/it
+@dirrm %%DATADIR%%/dat/descript/ja
+@dirrm %%DATADIR%%/dat/descript/ko
+@dirrm %%DATADIR%%/dat/descript/lt
+@dirrm %%DATADIR%%/dat/descript/lv
+@dirrm %%DATADIR%%/dat/descript/nl
+@dirrm %%DATADIR%%/dat/descript/pl
+@dirrm %%DATADIR%%/dat/descript/pt
+@dirrm %%DATADIR%%/dat/descript/ru
+@dirrm %%DATADIR%%/dat/descript/tr
+@dirrm %%DATADIR%%/dat/descript/zh
+@dirrm %%DATADIR%%/dat/descript
+@dirrm %%DATADIR%%/dat/dlua/layout
+@dirrm %%DATADIR%%/dat/dlua
+%%SDL%%@dirrm %%DATADIR%%/dat/tiles
+@dirrm %%DATADIR%%/dat
+@dirrm %%DATADIR%%/docs/develop/levels
+@dirrm %%DATADIR%%/docs/develop
+@dirrm %%DATADIR%%/docs/license
+@dirrm %%DATADIR%%/docs
+@dirrm %%DATADIR%%/settings
+@dirrm %%DATADIR%%