aboutsummaryrefslogtreecommitdiff
path: root/games/sturmbahnfahrer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/sturmbahnfahrer/Makefile')
-rw-r--r--games/sturmbahnfahrer/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/games/sturmbahnfahrer/Makefile b/games/sturmbahnfahrer/Makefile
new file mode 100644
index 000000000000..35f464dd779d
--- /dev/null
+++ b/games/sturmbahnfahrer/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: sturmbahnfahrer
+# Date created: 07 Sep 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sturmbahnfahrer
+PORTVERSION= 1.3
+CATEGORIES= games
+MASTER_SITES= http://www.stolk.org/sturmbahnfahrer/download/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Simulated obstacle course for automobiles
+
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+BUILD_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
+ ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
+
+USE_GL= yes
+USE_GCC= 3.4+
+
+MAKE_ENV= DATADIR="${DATADIR}"
+
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on FreeBSD 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/games/sturmbahnfahrer|${DATADIR}|' \
+ ${WRKSRC}/main.cxx
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>